summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-05 10:31:47 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-05 10:32:17 +0200
commit1ab9f82575f6a4997534944704bada56c5a38bb2 (patch)
tree41009dfae2fda49e809367f1819c5de40cd0c51c
parentmedia-gfx/povray-3.7.0.0-r1: add alpha keyword (diff)
downloadgentoo-1ab9f82575f6a4997534944704bada56c5a38bb2.tar.gz
gentoo-1ab9f82575f6a4997534944704bada56c5a38bb2.tar.bz2
gentoo-1ab9f82575f6a4997534944704bada56c5a38bb2.zip
net-analyzer/wireshark: Clean up USE flags / configure options (bug #587922).
Package-Manager: portage-2.3.0
-rw-r--r--net-analyzer/wireshark/wireshark-2.1.0.ebuild32
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild40
2 files changed, 34 insertions, 38 deletions
diff --git a/net-analyzer/wireshark/wireshark-2.1.0.ebuild b/net-analyzer/wireshark/wireshark-2.1.0.ebuild
index f3c3d5498553..66e32b8fac7d 100644
--- a/net-analyzer/wireshark/wireshark-2.1.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-2.1.0.ebuild
@@ -13,9 +13,9 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="
- adns androiddump +caps crypt doc doc-pdf geoip +gtk3 ipv6 kerberos lua
- +netlink +pcap portaudio +qt4 qt5 selinux sbc smi tfshark
- cpu_flags_x86_sse4_2 ssl zlib
+ adns androiddump +caps cpu_flags_x86_sse4_2 crypt doc doc-pdf geoip +gtk
+ kerberos lua +netlink +pcap portaudio +qt4 qt5 sbc selinux smi ssl tfshark
+ zlib
"
REQUIRED_USE="
ssl? ( crypt )
@@ -24,11 +24,6 @@ REQUIRED_USE="
S=${WORKDIR}/${P/_/}
-GTK_COMMON_DEPEND="
- x11-libs/gdk-pixbuf
- x11-libs/pango
- x11-misc/xdg-utils
-"
CDEPEND="
>=dev-libs/glib-2.14:2
netlink? ( dev-libs/libnl:3 )
@@ -36,9 +31,11 @@ CDEPEND="
crypt? ( dev-libs/libgcrypt:0 )
caps? ( sys-libs/libcap )
geoip? ( dev-libs/geoip )
- gtk3? (
- ${GTK_COMMON_DEPEND}
+ gtk? (
+ x11-libs/gdk-pixbuf
x11-libs/gtk+:3
+ x11-libs/pango
+ x11-misc/xdg-utils
)
kerberos? ( virtual/krb5 )
lua? ( >=dev-lang/lua-5.1:* )
@@ -83,7 +80,7 @@ DEPEND="
"
RDEPEND="
${CDEPEND}
- gtk3? ( virtual/freedesktop-icon-theme )
+ gtk? ( virtual/freedesktop-icon-theme )
qt4? ( virtual/freedesktop-icon-theme )
qt5? ( virtual/freedesktop-icon-theme )
selinux? ( sec-policy/selinux-wireshark )
@@ -121,7 +118,7 @@ src_configure() {
fi
# Enable wireshark binary with any supported GUI toolkit (bug #473188)
- if use gtk3 || use qt4 || use qt5; then
+ if use gtk || use qt4 || use qt5; then
myconf+=( "--enable-wireshark" )
else
myconf+=( "--disable-wireshark" )
@@ -149,23 +146,22 @@ src_configure() {
econf \
$(use androiddump && use pcap && echo --enable-androiddump-use-libpcap=yes) \
$(use_enable androiddump) \
- $(use_enable ipv6) \
$(use_enable tfshark) \
$(use_with adns c-ares) \
$(use_with caps libcap) \
$(use_with crypt gcrypt) \
$(use_with geoip) \
- $(use_with gtk3) \
+ $(use_with gtk gtk 3) \
$(use_with kerberos krb5) \
$(use_with lua) \
$(use_with pcap dumpcap-group wireshark) \
$(use_with pcap) \
$(use_with portaudio) \
$(usex qt4 --with-qt=4 '') \
- $(usex qt5 --with-qt=5 '') \
$(usex qt4 MOC=$(qt4_get_bindir)/moc '') \
$(usex qt4 RCC=$(qt4_get_bindir)/rcc '') \
$(usex qt4 UIC=$(qt4_get_bindir)/uic '') \
+ $(usex qt5 --with-qt=5 '') \
$(usex qt5 MOC=$(qt5_get_bindir)/moc '') \
$(usex qt5 RCC=$(qt5_get_bindir)/rcc '') \
$(usex qt5 UIC=$(qt5_get_bindir)/uic '') \
@@ -176,15 +172,14 @@ src_configure() {
$(usex netlink --with-libnl=3 --without-libnl) \
$(usex cpu_flags_x86_sse4_2 --enable-sse4_2 '') \
--disable-profile-build \
- --disable-usr-local \
--disable-warnings-as-errors \
--sysconfdir="${EPREFIX}"/etc/wireshark \
- --without-adns \
${myconf[@]}
}
src_compile() {
default
+
if use doc; then
emake -j1 -C docbook
if use doc-pdf; then
@@ -192,7 +187,6 @@ src_compile() {
emake -C docbook all-pdf
fi
fi
-
}
src_install() {
@@ -233,7 +227,7 @@ src_install() {
insinto /usr/include/wiretap
doins wiretap/wtap.h
- if use gtk3 || use qt4 || use qt5; then
+ if use gtk || use qt4 || use qt5; then
local c d
for c in hi lo; do
for d in 16 32 48; do
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 7284d2fe4a04..fd9b8c9079b4 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,20 +13,15 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="
- adns androiddump +caps cpu_flags_x86_sse4_2 crypt doc doc-pdf geoip +gtk3
- ipv6 kerberos lua +netlink +pcap portaudio +qt4 qt5 sbc selinux smi ssl
- tfshark zlib
+ adns androiddump +caps cpu_flags_x86_sse4_2 crypt doc doc-pdf geoip +gtk
+ kerberos lua +netlink +pcap portaudio +qt4 qt5 sbc selinux smi ssl tfshark
+ zlib
"
REQUIRED_USE="
ssl? ( crypt )
?? ( qt4 qt5 )
"
-GTK_COMMON_DEPEND="
- x11-libs/gdk-pixbuf
- x11-libs/pango
- x11-misc/xdg-utils
-"
CDEPEND="
>=dev-libs/glib-2.14:2
netlink? ( dev-libs/libnl:3 )
@@ -34,9 +29,11 @@ CDEPEND="
crypt? ( dev-libs/libgcrypt:0 )
caps? ( sys-libs/libcap )
geoip? ( dev-libs/geoip )
- gtk3? (
- ${GTK_COMMON_DEPEND}
+ gtk? (
+ x11-libs/gdk-pixbuf
x11-libs/gtk+:3
+ x11-libs/pango
+ x11-misc/xdg-utils
)
kerberos? ( virtual/krb5 )
lua? ( >=dev-lang/lua-5.1:* )
@@ -57,7 +54,7 @@ CDEPEND="
)
sbc? ( media-libs/sbc )
smi? ( net-libs/libsmi )
- ssl? ( net-libs/gnutls )
+ ssl? ( net-libs/gnutls:= )
zlib? ( sys-libs/zlib !=sys-libs/zlib-1.2.4 )
"
# We need perl for `pod2html`. The rest of the perl stuff is to block older
@@ -81,7 +78,7 @@ DEPEND="
"
RDEPEND="
${CDEPEND}
- gtk3? ( virtual/freedesktop-icon-theme )
+ gtk? ( virtual/freedesktop-icon-theme )
qt4? ( virtual/freedesktop-icon-theme )
qt5? ( virtual/freedesktop-icon-theme )
selinux? ( sec-policy/selinux-wireshark )
@@ -123,7 +120,7 @@ src_configure() {
fi
# Enable wireshark binary with any supported GUI toolkit (bug #473188)
- if use gtk3 || use qt4 || use qt5; then
+ if use gtk || use qt4 || use qt5; then
myconf+=( "--enable-wireshark" )
else
myconf+=( "--disable-wireshark" )
@@ -158,15 +155,17 @@ src_configure() {
$(use_with caps libcap) \
$(use_with crypt gcrypt) \
$(use_with geoip) \
- $(use_with gtk3) \
+ $(use_with gtk gtk 3) \
$(use_with kerberos krb5) \
$(use_with lua) \
$(use_with pcap dumpcap-group wireshark) \
$(use_with pcap) \
$(use_with portaudio) \
+ $(usex qt4 --with-qt=4 '') \
$(usex qt4 MOC=$(qt4_get_bindir)/moc '') \
$(usex qt4 RCC=$(qt4_get_bindir)/rcc '') \
$(usex qt4 UIC=$(qt4_get_bindir)/uic '') \
+ $(usex qt5 --with-qt=5 '') \
$(usex qt5 MOC=$(qt5_get_bindir)/moc '') \
$(usex qt5 RCC=$(qt5_get_bindir)/rcc '') \
$(usex qt5 UIC=$(qt5_get_bindir)/uic '') \
@@ -177,23 +176,26 @@ src_configure() {
$(usex netlink --with-libnl=3 --without-libnl) \
$(usex cpu_flags_x86_sse4_2 --enable-sse4_2 '') \
--disable-profile-build \
- --disable-usr-local \
--disable-warnings-as-errors \
--sysconfdir="${EPREFIX}"/etc/wireshark \
- --without-adns \
${myconf[@]}
}
src_compile() {
default
+
if use doc; then
- use doc-pdf && addpredict "/root/.java"
emake -j1 -C docbook
+ if use doc-pdf; then
+ addpredict "/root/.java"
+ emake -C docbook all-pdf
+ fi
fi
}
src_install() {
default
+
if use doc; then
dohtml -r docbook/{release-notes.html,ws{d,u}g_html{,_chunked}}
if use doc-pdf; then
@@ -229,7 +231,7 @@ src_install() {
insinto /usr/include/wiretap
doins wiretap/wtap.h
- if use gtk3 || use qt4 || use qt5; then
+ if use gtk || use qt4 || use qt5; then
local c d
for c in hi lo; do
for d in 16 32 48; do