summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-07-25 11:46:02 -0400
committerIan Stakenvicius <axs@gentoo.org>2016-07-25 12:21:24 -0400
commit1b8d26f9d99f988a16193b3f1e40a078ea1bc682 (patch)
tree5ed88838f45e16436ab52b6bb632536b599e238f
parentnet-mail/lbdb: version bump to 0.41 (diff)
downloadgentoo-1b8d26f9d99f988a16193b3f1e40a078ea1bc682.tar.gz
gentoo-1b8d26f9d99f988a16193b3f1e40a078ea1bc682.tar.bz2
gentoo-1b8d26f9d99f988a16193b3f1e40a078ea1bc682.zip
sys-fs/dmraid: ensure REPLACING_VERSIONS is handled when it is a list
..and also fix intentation Bug: http://bugs.gentoo.org/589528 Package-Manager: portage-2.2.28
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild37
1 files changed, 19 insertions, 18 deletions
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild
index 93f8ededd677..3b1934872df7 100644
--- a/sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc16-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -75,25 +75,26 @@ src_install() {
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "For booting Gentoo from Device-Mapper RAID you can use a Genkernel initramfs."
- elog
- elog "Genkernel will generate the kernel and the initramfs with a statically "
- elog "linked dmraid binary (its own version which may not be the same as this version):"
- elog "\t emerge -av sys-kernel/genkernel"
- elog "\t genkernel --dmraid all"
+ elog "For booting Gentoo from Device-Mapper RAID you can use a Genkernel initramfs."
+ elog
+ elog "Genkernel will generate the kernel and the initramfs with a statically "
+ elog "linked dmraid binary (its own version which may not be the same as this version):"
+ elog "\t emerge -av sys-kernel/genkernel"
+ elog "\t genkernel --dmraid all"
fi
- if [[ ${REPLACING_VERSIONS} != ${PVR} ]]; then
- elog
- elog "A pre-patched distfile of this version of DMRAID has been installed at"
- elog "/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2 , to support using it within a"
- elog "Genkernel initramfs."
- elog
+ # skip this message if this revision has already been emerged
+ if [[ " ${REPLACING_VERSIONS} " != *\ ${PVR}\ * ]]; then
+ elog
+ elog "A pre-patched distfile of this version of DMRAID has been installed at"
+ elog "/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2 , to support using it within a"
+ elog "Genkernel initramfs."
+ elog
fi
if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "If you would rather use this version of DMRAID with Genkernel, update the following"
- elog "in /etc/genkernel.conf:"
- elog "\t DMRAID_VER=\"${MY_PV}\""
- elog "\t DMRAID_SRCTAR=\"/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2\""
- elog
+ elog "If you would rather use this version of DMRAID with Genkernel, update the following"
+ elog "in /etc/genkernel.conf:"
+ elog "\t DMRAID_VER=\"${MY_PV}\""
+ elog "\t DMRAID_SRCTAR=\"/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2\""
+ elog
fi
}