summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-09 10:35:26 -0500
committerBrian Evans <grknight@gentoo.org>2017-03-09 11:22:05 -0500
commit1bfae2f22a07d71c690d69ed2a6d9efe06bf2eeb (patch)
treeb6c96f086a37a4e749b9252d7e84bd4bb06df2ab
parentdev-php/doctrine-instantiator: New package for an unbundled phpunit (diff)
downloadgentoo-1bfae2f22a07d71c690d69ed2a6d9efe06bf2eeb.tar.gz
gentoo-1bfae2f22a07d71c690d69ed2a6d9efe06bf2eeb.tar.bz2
gentoo-1bfae2f22a07d71c690d69ed2a6d9efe06bf2eeb.zip
dev-php/phpdocumentor-reflection-common: New package for an unbundled phpunit
Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--dev-php/phpdocumentor-reflection-common/Manifest1
-rw-r--r--dev-php/phpdocumentor-reflection-common/files/autoload.php8
-rw-r--r--dev-php/phpdocumentor-reflection-common/metadata.xml8
-rw-r--r--dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild27
4 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/phpdocumentor-reflection-common/Manifest b/dev-php/phpdocumentor-reflection-common/Manifest
new file mode 100644
index 000000000000..a6feb054c19f
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/Manifest
@@ -0,0 +1 @@
+DIST phpdocumentor-reflection-common-1.0.tar.gz 7746 SHA256 f53df95e812fc0208ba6aeef9e9fab95e5896ba3327d3f724ce03f0a17000b97 SHA512 63d76282d0921535af70e084d3621d8cc6b07f49bc5348429a340730212f3c99f8e64636e43cebb3140fa4f6363b4f2a0c02cbe38036a28123e7bbeb67c61a0d WHIRLPOOL e895a96359b4474012be2ad806cd4d4148564090a4b517f3651f531ada0ec3a2ada889b236b85219a4b1fe61272aa5c70192ad193177b66b571960eee7eb56ae
diff --git a/dev-php/phpdocumentor-reflection-common/files/autoload.php b/dev-php/phpdocumentor-reflection-common/files/autoload.php
new file mode 100644
index 000000000000..356515b7a000
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for dev-php/phpdocumentor-reflection-common */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+Fedora\Autoloader\Autoload::addPsr4('phpDocumentor\\Reflection\\', __DIR__);
diff --git a/dev-php/phpdocumentor-reflection-common/metadata.xml b/dev-php/phpdocumentor-reflection-common/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild b/dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild
new file mode 100644
index 000000000000..654a82f3d07a
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="ReflectionCommon"
+MY_VENDOR="phpDocumentor"
+
+DESCRIPTION="Common reflection classes used by phpdocumentor to reflect the code structure"
+HOMEPAGE="https://www.phpdoc.org"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/${MY_PN}
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}