summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-11-07 14:19:27 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-11-07 14:19:56 +0100
commit1cdbf3d25da15e5b17d33b5182822147ed918a84 (patch)
tree436a9a2e244336eea3e4a46d06e464a6230b5fd3
parentmedia-video/mkvtoolnix: Drop unneeded WX variable (#562484#c5) (diff)
downloadgentoo-1cdbf3d25da15e5b17d33b5182822147ed918a84.tar.gz
gentoo-1cdbf3d25da15e5b17d33b5182822147ed918a84.tar.bz2
gentoo-1cdbf3d25da15e5b17d33b5182822147ed918a84.zip
app-portage/eix: Version bump
Package-Manager: portage-2.2.24
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.31.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 265410132bd5..f853c2ad99f2 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -4,3 +4,4 @@ DIST eix-0.30.4.tar.xz 556632 SHA256 4c753a82e15ce0f8bbdd74edcebb7bc23bd3de8dfca
DIST eix-0.30.7.tar.xz 558144 SHA256 ed000a8430ffb1c9087807d2ef686b10252d9b199e67c88f7bce11077a371473 SHA512 babb23176e68d47bcc5d899090abb326eae6b3ce4c587a6cf977c6216d193f4cf93dd54a647e50f08434440e022f117c8e5f800f1db2c048220bd229fd6cd4f5 WHIRLPOOL 0a27efa1c8003ae23ab96cb93672f38120828dc75cc333450e19026b7505c19ee411b42261049192c009a57b22c15c9ed5c9b7875171a039b21bbc142d220904
DIST eix-0.30.8.tar.xz 559076 SHA256 525c5d0276b8d40de012668af36042ecb674175c3b92fb9214c3f1f1b0dacaec SHA512 ee1901037507d3e527d5e37338efb4b9c38c4d42efae042918d0e24e8bd08ece0064ac2efec960fc3280bc2bb14b46d87b66d6c04aa634c8737276321f580255 WHIRLPOOL d29d6cf704ef331621cf9b6e37433de643b43cc8b079295cbaa6f25979a399ef0b5e72ddaee3de205b8dd831de946e16b96d5c1f9b63666027a5a9b8f6d24e08
DIST eix-0.31.1.tar.bz2 791116 SHA256 1402d474ee3d1dc6fcfe35508657629d4a5aef6cbe1913687fa65c8e139f3fdf SHA512 7fdd579f884f92bf58a876c89c4f397610c2af8da0c47382bf25b8d4919d1f24713fd8029ab82c73a9be382e51b1aac78476d006961620f12c0386fe864b6c22 WHIRLPOOL 3ea640ab80a6119497323312b4b527aa8060597ed09d29a43d68abf3ae20bafeb793c6df1890a2e433f5d77485b14dfa507795fc7e9e0d7e2b69dd16668c5aa8
+DIST eix-0.31.2.tar.bz2 787190 SHA256 c03226d0971067561e931c0afe75878552a6178ede7326601c3a839b289c72d9 SHA512 61a7f58ba48030000bd4ca50575aec95ba7726c12d935bd1fa7a2b28440fbc66a272fc727bc6a2b7716e285d3b93b7a888cef017c66d8682f29e9388dc89a6a1 WHIRLPOOL d67ab5ee83ab74c895f5e7345b40a7313c1ad1a1a2af184f54e5481eed9f6134920c172fe1dcae0522b2d965832e76cfbe14020181d799eff04a1afc6938af64
diff --git a/app-portage/eix/eix-0.31.2.ebuild b/app-portage/eix/eix-0.31.2.ebuild
new file mode 100644
index 000000000000..6579e25c97c5
--- /dev/null
+++ b/app-portage/eix/eix-0.31.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="de ru"
+inherit bash-completion-r1 eutils l10n
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
+
+BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )"
+RDEPEND="${BOTHDEPEND}
+ app-shells/push"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ case " ${REPLACING_VERSIONS}" in
+ *\ 0.[0-9].*|*\ 0.1[0-9].*|*\ 0.2[0-4].*|*\ 0.25.0*)
+ local eixcache="${EROOT}/var/cache/${PN}"
+ test -f "${eixcache}" && rm -f -- "${eixcache}";;
+ esac
+}
+
+src_prepare() {
+ sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
+ epatch_user
+}
+
+src_configure() {
+ econf $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable security) $(use_enable optimization) \
+ $(use_enable strong-security) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_enable swap-remote) \
+ $(use_with prefix always-accept-keywords) \
+ $(use_with dep dep-default) \
+ --with-zsh-completion \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ insinto "/usr/lib/tmpfiles.d"
+ doins tmpfiles.d/eix.conf
+}
+
+pkg_postinst() {
+ test -d "${EROOT}var/cache/${PN}" || {
+ mkdir "${EROOT}var/cache/${PN}"
+ use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+ }
+ local obs="${EROOT}var/cache/eix.previous"
+ ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
+}
+
+pkg_postrm() {
+ [ -n "${REPLACED_BY_VERSION}" ] || rm -rf -- "${EROOT}var/cache/${PN}"
+}