summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-26 20:50:00 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 20:50:00 +0100
commit1d15abdb6f7025939c3a8d2811af7412ce472420 (patch)
tree57bf9ecd598f05a92ebaf517ce14b2be1c6d0a30
parentgames-board/stockfish: drop old (diff)
parentmedia-libs/portaudio: Version bump (diff)
downloadgentoo-1d15abdb6f7025939c3a8d2811af7412ce472420.tar.gz
gentoo-1d15abdb6f7025939c3a8d2811af7412ce472420.tar.bz2
gentoo-1d15abdb6f7025939c3a8d2811af7412ce472420.zip
Merge remote-tracking branch 'github/pr/3514'
-rw-r--r--media-libs/portaudio/Manifest1
-rw-r--r--media-libs/portaudio/portaudio-19.06.00.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/portaudio/Manifest b/media-libs/portaudio/Manifest
index eca7fd9f15b7..b4dd55ee0926 100644
--- a/media-libs/portaudio/Manifest
+++ b/media-libs/portaudio/Manifest
@@ -1 +1,2 @@
+DIST pa_stable_v190600_20161030.tgz 1450572 SHA256 f5a21d7dcd6ee84397446fa1fa1a0675bb2e8a4a6dceb4305a8404698d8d1513 SHA512 7ec692cbd8c23878b029fad9d9fd63a021f57e60c4921f602995a2fca070c29f17a280c7f2da5966c4aad29d28434538452f4c822eacf3a60af59a6dc8e9704c WHIRLPOOL c72e2e94c99659ce439840fa2ee56fa7e1bf499601c89e6d891b6a800e4987f3fb4f90c5a4a4cf3e4ae271108f7e8240c5b46c05d8f2b32ac5e15cd3b6c6bf5d
DIST pa_stable_v19_20140130.tgz 1504620 SHA256 8fe024a5f0681e112c6979808f684c3516061cc51d3acc0b726af98fc96c8d57 SHA512 078adfdc2cec7fbd4019837eee65f8411b873b51064dfd7334e1c55118c26ea1fb68cb22e46ee69adb69c78d026b00a7ed973c40632e7d79703e12669a62ee3e WHIRLPOOL a86777a4f3af59b64248d14522820a06fc9171fd5de88a2f688b2cc3e39d2374bc4f9d0c39b041fcf189f8db074810597056b45dfde80cbe4cfa7579cd30f3f9
diff --git a/media-libs/portaudio/portaudio-19.06.00.ebuild b/media-libs/portaudio/portaudio-19.06.00.ebuild
new file mode 100644
index 000000000000..5730c51376ec
--- /dev/null
+++ b/media-libs/portaudio/portaudio-19.06.00.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+inherit autotools-multilib
+
+DESCRIPTION="A free, cross-platform, open-source, audio I/O library"
+HOMEPAGE="http://www.portaudio.com/"
+SRC_URI="http://www.portaudio.com/archives/pa_stable_v190600_20161030.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="alsa +cxx debug jack oss static-libs"
+
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r8
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+DOCS=( README.txt )
+HTML_DOCS=( index.html )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-output)
+ $(use_enable cxx)
+ $(use_with alsa)
+ $(use_with jack)
+ $(use_with oss)
+ )
+
+ autotools-multilib_src_configure
+}
+
+src_compile() {
+ autotools-multilib_src_compile lib/libportaudio.la
+ autotools-multilib_src_compile
+}