summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2020-05-20 00:20:10 +0200
committerSven Wegener <swegener@gentoo.org>2020-05-20 00:20:16 +0200
commit1d2b4d675227f5595d039468111f21c5de183720 (patch)
treec6825d26d3c1133fd2f1ba8f54472c6168b970f4
parentnet-libs/nodejs: Version 14.3.0 (diff)
downloadgentoo-1d2b4d675227f5595d039468111f21c5de183720.tar.gz
gentoo-1d2b4d675227f5595d039468111f21c5de183720.tar.bz2
gentoo-1d2b4d675227f5595d039468111f21c5de183720.zip
net-dns/pdns-recursor: Version bump, security bug #723986
Bug: https://bugs.gentoo.org/723986 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sven Wegener <swegener@gentoo.org>
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.3.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 353ff91c3198..71108799dd63 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -3,3 +3,4 @@ DIST pdns-recursor-4.1.15.tar.bz2 1252518 BLAKE2B 11eecf1ca69e6855be1cb1a1a6bfef
DIST pdns-recursor-4.2.0.tar.bz2 1316156 BLAKE2B 3ceb71695b0d5aa2826e28975f45d03910b23f2d7dfbe7388ffd19ea51c37bf6758ea6f90f1772b0c4ed217ef844e112961f51c04dee4db20a05f1e25ae6b71f SHA512 e4be63c1be70f0dfd7aab71f1184d5cc1d15e60e775451a96e8472db6fb3825762ebd6f51b593b167389868bbfde0538612b14a04c03f3f60a7e49f7882e78bf
DIST pdns-recursor-4.2.1.tar.bz2 1318022 BLAKE2B 19fba9dae26d27f68ceaf70f15f2fb27ec030fa64d5dfdfe7bf482293ed5aac6b8eb6ed47a75c2b88f4d481794695d66f0ce1cbc71d8eedeabd86d8ce8c382ba SHA512 ebd7ff40def4b5c9398dee5ceae0aaf762982be4124773002b3f603b18cab2a6df667524a268e72268032334ae29d32b42294cbae68dcdc154e08b8a38f75dff
DIST pdns-recursor-4.3.0.tar.bz2 1349359 BLAKE2B cdb9d38a350ef371c3675185c0f52f416d55338df034ff32a9d9fc85d783de04513555ec96fbc1dd07ecd7214d889cfe6fba80bc6981e66a6b8d4fe6f1da7dfa SHA512 6ba4721f502e1e483d04e8d8cafa35d1cc088c6b3c73120a0cc90ff9c8e8f495a1591e01f0daf30d00f020e3aa06b1cf092ed6b8a0786070c307a6564812c085
+DIST pdns-recursor-4.3.1.tar.bz2 1334817 BLAKE2B 1972259e42b1cefd9069a36d2bb235652ce234d525a2e3f19c96a93bf26f34063e6d04240146bba0560573c1d2ad042a579d6ab557fc7ac0aadee09fa15ee397 SHA512 49ae4957ef202f94ec87e6449dfa9c147689b5576ca1002e0155319099d698300c113e221571f6d41cb1cdc1649619621c2ccf8105620c25452ac30bd83e46b8
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.3.1.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.3.1.ebuild
new file mode 100644
index 000000000000..fa5437a3d388
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.3.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug libressl luajit protobuf snmp sodium systemd"
+
+DEPEND="!luajit? ( >=dev-lang/lua-5.1:= )
+ luajit? ( dev-lang/luajit:= )
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42:=
+ )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:= )
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-lua=$(usex luajit luajit lua) \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_with sodium libsodium) \
+ $(use_with protobuf) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}