summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-12-13 14:57:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-12-14 10:22:49 +0100
commit1da8ab836aaa3a850454a0d32d3251a82fee23cc (patch)
tree6997f08c755253550b09e06e10b148d20d4b1597
parentkde-plasma/kwayland-server: drop 5.22.5* (diff)
downloadgentoo-1da8ab836aaa3a850454a0d32d3251a82fee23cc.tar.gz
gentoo-1da8ab836aaa3a850454a0d32d3251a82fee23cc.tar.bz2
gentoo-1da8ab836aaa3a850454a0d32d3251a82fee23cc.zip
kde-plasma/kwin: drop 5.22.5*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/kwin/Manifest1
-rw-r--r--kde-plasma/kwin/files/kwin-5.22.5-libglvnd-1.3.4.patch63
-rw-r--r--kde-plasma/kwin/kwin-5.22.5.ebuild142
3 files changed, 0 insertions, 206 deletions
diff --git a/kde-plasma/kwin/Manifest b/kde-plasma/kwin/Manifest
index 6adab4bef8f7..bc88bd028d7d 100644
--- a/kde-plasma/kwin/Manifest
+++ b/kde-plasma/kwin/Manifest
@@ -1,2 +1 @@
-DIST kwin-5.22.5.tar.xz 6459916 BLAKE2B caaec435be180fd4c359bea2d1f4a9a0e3e5854f73b91b83d62ad4e488e9d779a7f6bc5620dfb2ebcf5629b2f90c958d4a4a126df34c9734220c64262e751fba SHA512 4e466f3961279610c16d24c1dbc6368862308ee7bf677bf9f8ed1898465aa31263a34362b1beaad451b6c5e94068d908718c7bb37d12b814f2af9a1eccf417d2
DIST kwin-5.23.4.tar.xz 6341720 BLAKE2B 5dd984c0ff4c62f9d3e4915be5f5423477314a79c4e8fa9a0c306f99be968ca99e61ab9f23ee1b866e171c40c0ad173c96f6de49a28b2eea3a2c62bf5c9a20b3 SHA512 82da0883cf5e900c2278351e815453e25052edfb6534e4be015636dcc2c4051f154c6685eb2542e851d48bf8026bf2b359189864dda336b266208344dcfc851d
diff --git a/kde-plasma/kwin/files/kwin-5.22.5-libglvnd-1.3.4.patch b/kde-plasma/kwin/files/kwin-5.22.5-libglvnd-1.3.4.patch
deleted file mode 100644
index d185d5e41fe6..000000000000
--- a/kde-plasma/kwin/files/kwin-5.22.5-libglvnd-1.3.4.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 839710201c389b7f4ed248cb3818e755a37ce977 Mon Sep 17 00:00:00 2001
-From: Vlad Zahorodnii <vlad.zahorodnii@kde.org>
-Date: Fri, 10 Sep 2021 13:36:04 +0300
-Subject: [PATCH] x11: Fix build with EGL_NO_PLATFORM_SPECIFIC_TYPES
-
-eglCreateWindowSurface() wants a Window (unsigned long), but with
-EGL_NO_PLATFORM_SPECIFIC_TYPES, EGLNativeWindowType is defined as an
-opaque pointer, i.e. void*.
-
-BUG: 440372
-
-* asturm 2021-09-21: Merged with upstream commits:
-38e24ecd6416a975db0989c21b70d6a4cc242f35 "Fix build with 32-bit"
-e26ea6bf2313c021db7e5ca5454cd8b1e2e2037f "Fix build on 32bit platforms"
-
-* asturm 2021-10-04: Merged with upstream commit:
-From df11acd46778e1e43183c2660bc9dcb1a8ad3282 Mon Sep 17 00:00:00 2001
-From: Vlad Zahorodnii <vlad.zahorodnii@kde.org>
-Date: Tue, 21 Sep 2021 17:34:59 +0300
-Subject: [PATCH] x11: Cast Window to EGLNativeWindowType using a C cast
-
-reinterpret_cast<>() will fail if the types we cast from and to have
-mismatching sizes.
-
-Unfortunately, there are platforms that have Window and
-EGLNativeWindowType of different size. This results in compilation
-errors.
-
-In order to work around those problematic platforms, this change
-replaces reinterpret_cast cast with a c style cast.
----
- src/plugins/platforms/x11/common/eglonxbackend.cpp | 16 +++++++++------
- 1 file changed, 10 insertions(+), 6 deletions(-)
-
-diff -u a/src/plugins/platforms/x11/common/eglonxbackend.cpp b/src/plugins/platforms/x11/common/eglonxbackend.cpp
---- a/src/plugins/platforms/x11/common/eglonxbackend.cpp
-+++ b/src/plugins/platforms/x11/common/eglonxbackend.cpp
-@@ -213,15 +213,19 @@
- return EGL_NO_SURFACE;
- }
-
-+ // Window is 64 bits on a 64-bit architecture whereas xcb_window_t is always 32 bits.
-+ Window nativeWindow = window;
-+
- EGLSurface surface = EGL_NO_SURFACE;
- if (havePlatformBase()) {
-- // Note: Window is 64 bits on a 64-bit architecture whereas xcb_window_t is
-- // always 32 bits. eglCreatePlatformWindowSurfaceEXT() expects the
-- // native_window parameter to be pointer to a Window, so this variable
-- // cannot be an xcb_window_t.
-- surface = eglCreatePlatformWindowSurfaceEXT(eglDisplay(), config(), (void *) &window, nullptr);
-+ // eglCreatePlatformWindowSurfaceEXT() expects a pointer to the Window.
-+ surface = eglCreatePlatformWindowSurfaceEXT(eglDisplay(), config(), (void *) &nativeWindow, nullptr);
- } else {
-- surface = eglCreateWindowSurface(eglDisplay(), config(), window, nullptr);
-+ // eglCreateWindowSurface() expects a Window, not a pointer to the Window. Use
-+ // a c style cast as there are (buggy) platforms where the size of the Window
-+ // type is not the same as the size of EGLNativeWindowType, reinterpret_cast<>()
-+ // may not compile.
-+ surface = eglCreateWindowSurface(eglDisplay(), config(), (EGLNativeWindowType) nativeWindow, nullptr);
- }
-
- return surface;
diff --git a/kde-plasma/kwin/kwin-5.22.5.ebuild b/kde-plasma/kwin/kwin-5.22.5.ebuild
deleted file mode 100644
index 43b14d49330f..000000000000
--- a/kde-plasma/kwin/kwin-5.22.5.ebuild
+++ /dev/null
@@ -1,142 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_HANDBOOK="optional"
-ECM_TEST="optional"
-KFMIN=5.82.0
-PVCUT=$(ver_cut 1-3)
-QTMIN=5.15.2
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org optfeature
-
-DESCRIPTION="Flexible, composited Window Manager for windowing systems on Linux"
-
-LICENSE="GPL-2+"
-SLOT="5"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-IUSE="accessibility caps gles2-only multimedia plasma screencast"
-
-RESTRICT="test"
-
-COMMON_DEPEND="
- >=dev-libs/libinput-1.14
- >=dev-libs/wayland-1.2
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5=[gles2-only=,libinput]
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtx11extras-${QTMIN}:5
- >=kde-frameworks/kactivities-${KFMIN}:5
- >=kde-frameworks/kauth-${KFMIN}:5
- >=kde-frameworks/kcmutils-${KFMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdeclarative-${KFMIN}:5
- >=kde-frameworks/kglobalaccel-${KFMIN}:5=
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kidletime-${KFMIN}:5=
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/kpackage-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwayland-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5[X]
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=kde-frameworks/plasma-${KFMIN}:5
- >=kde-plasma/breeze-${PVCUT}:5
- >=kde-plasma/kdecoration-${PVCUT}:5
- >=kde-plasma/kscreenlocker-${PVCUT}:5
- >=kde-plasma/kwayland-server-${PVCUT}:5
- media-libs/fontconfig
- media-libs/freetype
- media-libs/lcms:2
- media-libs/libepoxy
- media-libs/mesa[egl(+),gbm(+),wayland,X(+)]
- virtual/libudev:=
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libdrm
- >=x11-libs/libxcb-1.10
- >=x11-libs/libxkbcommon-0.7.0
- x11-libs/xcb-util-cursor
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-wm
- accessibility? ( media-libs/libqaccessibilityclient:5 )
- caps? ( sys-libs/libcap )
- gles2-only? ( media-libs/mesa[gles2] )
- plasma? ( >=kde-frameworks/krunner-${KFMIN}:5 )
- screencast? ( >=media-video/pipewire-0.3:= )
-"
-# TODO: sys-apps/hwdata? not packaged yet; commit 33a1777a, Gentoo-bug 717216
-RDEPEND="${COMMON_DEPEND}
- >=dev-qt/qtquickcontrols-${QTMIN}:5
- >=dev-qt/qtquickcontrols2-${QTMIN}:5
- >=dev-qt/qtvirtualkeyboard-${QTMIN}:5
- >=kde-frameworks/kirigami-${KFMIN}:5
- >=kde-frameworks/kitemmodels-${KFMIN}:5[qml]
- || (
- x11-base/xwayland
- x11-base/xorg-server[wayland(-)]
- )
- multimedia? ( >=dev-qt/qtmultimedia-${QTMIN}:5[gstreamer,qml] )
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-qt/designer-${QTMIN}:5
- >=dev-qt/qtconcurrent-${QTMIN}:5
- x11-base/xorg-proto
- test? (
- >=dev-libs/wayland-protocols-1.19
- >=dev-qt/qtwayland-${QTMIN}:5
- )
-"
-PDEPEND="
- >=kde-plasma/kde-cli-tools-${PVCUT}:5
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-libglvnd-1.3.4.patch" # KDE-bug 440372, bugs 810511, 813228
-)
-
-src_prepare() {
- ecm_src_prepare
- use multimedia || eapply "${FILESDIR}/${PN}-5.21.80-gstreamer-optional.patch"
-
- # TODO: try to get a build switch upstreamed
- if ! use screencast; then
- sed -e "s/^pkg_check_modules.*PipeWire/#&/" \
- -i CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package accessibility QAccessibilityClient)
- $(cmake_use_find_package caps Libcap)
- $(cmake_use_find_package plasma KF5Runner)
- )
-
- ecm_src_configure
-}
-
-pkg_postinst() {
- ecm_pkg_postinst
- optfeature "color management support" x11-misc/colord
- elog
- elog "In Plasma 5.20, default behavior of the Task Switcher to move minimised"
- elog "windows to the end of the list was changed so that it remains in the"
- elog "original order. To revert to the well established behavior:"
- elog
- elog " - Edit ~/.config/kwinrc"
- elog " - Find [TabBox] section"
- elog " - Add \"MoveMinimizedWindowsToEndOfTabBoxFocusChain=true\""
-}