summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-07-15 08:44:30 -0400
committerBrian Evans <grknight@gentoo.org>2016-07-15 08:49:17 -0400
commit1dd3df55b5de52df4b04db77748e983045c16550 (patch)
tree1cf87426ba780f5d9ebd94e250bac053fec1bed2
parentnet-im/telepathy-mission-control: Pointless commit to enforce regeneration of... (diff)
downloadgentoo-1dd3df55b5de52df4b04db77748e983045c16550.tar.gz
gentoo-1dd3df55b5de52df4b04db77748e983045c16550.tar.bz2
gentoo-1dd3df55b5de52df4b04db77748e983045c16550.zip
dev-php/xcache: Drop old
Package-Manager: portage-2.3.0
-rw-r--r--dev-php/xcache/Manifest2
-rw-r--r--dev-php/xcache/xcache-3.0.4.ebuild59
-rw-r--r--dev-php/xcache/xcache-3.1.2.ebuild60
3 files changed, 0 insertions, 121 deletions
diff --git a/dev-php/xcache/Manifest b/dev-php/xcache/Manifest
index 1f5a5fadf231..f3de322a47d8 100644
--- a/dev-php/xcache/Manifest
+++ b/dev-php/xcache/Manifest
@@ -1,3 +1 @@
-DIST xcache-3.0.4.tar.bz2 142844 SHA256 447baab727b6b0d2955e10ce117f55d9a63d306def78c34837b4ff3d6c586a4e SHA512 99c7756e100ff844e8e995a1909e0bb66330631f208ac28b5008f172c19a98cd3e126481c6a8f35cff70d3360902ddd799a5aa6fb0148a2d3b462a52ca7e1fa0 WHIRLPOOL 2a2153f8e3240b6bca6287939f6bec3a4e1a539b81383d0f298944da4014c5b7c5be15e6f354c798f30c3a74d0b5ba49ea72b8185f89a8e2a0349f2f8a84df1a
-DIST xcache-3.1.2.tar.bz2 146408 SHA256 84cf9b38710c51aabd28987632999cae99f7869d4cb056752ed901a262fef98f SHA512 1ed32b5e781d2bcf32e15481b6277657701b1a0cb1f8ef96852cbe1f0c8621c1ffaa550920cb06b93f9f51b31d18bcfc49c477defcf558fea167a8eab4266b2a WHIRLPOOL e697552aad67d9a270cb5dc2628c8f47e99311ac787226c76c4044191c21e15797ce79341f8b39ef3ba5680fb8dc26ccd74e42d1a3fb44926c74b566cd3cea6f
DIST xcache-3.2.0.tar.bz2 148392 SHA256 7d12a3cbd5f729b70f9226ac19406d11219f1c5f5e82b3bbb43ea9460cbf6cbd SHA512 9d7bec73ac941c8e38b2cda15af65044291adc0806b39586048943515d67656d64871bea4ea05b3dff76761ebed462db2d6ad0e489079291abc55313b1508946 WHIRLPOOL 37eb83618f896037f7ca6f5a65e113c468b4ee03bf05421ee5f6907a1ad562f5794267970531eba4798ec517915ac9debde36f1d8dcabfe442ae75f1de5b0841
diff --git a/dev-php/xcache/xcache-3.0.4.ebuild b/dev-php/xcache/xcache-3.0.4.ebuild
deleted file mode 100644
index 701e15d261cd..000000000000
--- a/dev-php/xcache/xcache-3.0.4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PHP_EXT_NAME="xcache"
-PHP_EXT_INI="yes"
-PHPSAPILIST="apache2 cgi fpm"
-USE_PHP="php5-4"
-
-inherit php-ext-source-r2 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="
- !dev-php/eaccelerator
- !dev-php/pecl-apc
- virtual/httpd-php
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
-
- my_conf="--enable-xcache=shared \
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- --enable-xcache-coverager \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder"
-
- php-ext-source-r2_src_configure
-}
-
-src_install() {
- php-ext-source-r2_src_install
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins lib/Decompiler.class.php
- insinto "${PHP_EXT_SHARED_DIR}"
- doins -r htdocs
-}
-
-pkg_postinst() {
- elog "lib/Decompiler.class.php, and the htdocs/ directory shipped with this"
- elog "release were installed into ${PHP_EXT_SHARED_DIR}."
-}
diff --git a/dev-php/xcache/xcache-3.1.2.ebuild b/dev-php/xcache/xcache-3.1.2.ebuild
deleted file mode 100644
index e98818354c78..000000000000
--- a/dev-php/xcache/xcache-3.1.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PHP_EXT_NAME="xcache"
-PHP_EXT_INI="yes"
-PHPSAPILIST="apache2 cgi fpm"
-USE_PHP="php5-4 php5-5"
-
-inherit php-ext-source-r2 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="
- !dev-php/eaccelerator
- !dev-php/pecl-apc
- virtual/httpd-php
- php_targets_php5-5? ( !dev-lang/php:5.5[opcache] )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
-
- my_conf="--enable-xcache=shared \
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- --enable-xcache-coverager \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder"
-
- php-ext-source-r2_src_configure
-}
-
-src_install() {
- php-ext-source-r2_src_install
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins lib/Decompiler.class.php
- insinto "${PHP_EXT_SHARED_DIR}"
- doins -r htdocs
-}
-
-pkg_postinst() {
- elog "lib/Decompiler.class.php, and the htdocs/ directory shipped with this"
- elog "release were installed into ${PHP_EXT_SHARED_DIR}."
-}