summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-09-24 16:00:11 -0700
committerZac Medico <zmedico@gentoo.org>2017-09-24 16:08:06 -0700
commit204be586079a01aebce5ceccc588df36fadc1604 (patch)
tree6ef386948e53767f230c20647bc3adc4be6319bb
parentsys-apps/busybox: use https for git repo (diff)
downloadgentoo-204be586079a01aebce5ceccc588df36fadc1604.tar.gz
gentoo-204be586079a01aebce5ceccc588df36fadc1604.tar.bz2
gentoo-204be586079a01aebce5ceccc588df36fadc1604.zip
dev-python/python-engineio: version bump to 1.7.0
Package-Manager: Portage-2.3.10, Repoman-2.3.3
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-1.7.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index a6161647c665..41ee5aa67d2d 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1 +1,2 @@
DIST python-engineio-1.4.0.tar.gz 20829 SHA256 488f7761aaa4ab84ae4356755efe0e689de1dbc98052c9533a3f1aa9ce13e8c7 SHA512 ab32361d91b0c982a41f7fde7769912e13d8ea9acd9e99cbc36c84cedca2241a175b3b49582589b821457f13270b2beb0c90a9592b7b9dbf625d82fcc36504f5 WHIRLPOOL b9a8f3479c1d3e6c2fd1f14aa88775e09c3de9ce831d761912d03afb58b506232b364f07e4e8a76ebbab379a4f15649397c7a89cbcc65d572db5b3d34710dd47
+DIST python-engineio-1.7.0.tar.gz 22804 SHA256 fca35c7e4af42475552d53eea04a9280e2ccd331a032f41d17290ff3125a2291 SHA512 1d184ccb9d1328d9f4e2fa22006f1d21bd17200bc893ee2588b4342da24775f98648e0e993893eb56a9159f95a114f128dfdacef9fa8ea296c7ace6c7741aea0 WHIRLPOOL 9ad22f4a5964a84d266deec2dfe72d8a0c9719c759c31ab0d84b457e0e5489297d7748ee59338b1ae1919a7ff890a02a118cbb09fcb9063723af67df635904ca
diff --git a/dev-python/python-engineio/python-engineio-1.7.0.ebuild b/dev-python/python-engineio/python-engineio-1.7.0.ebuild
new file mode 100644
index 000000000000..6f3b26b71d31
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-1.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://${PN}.readthedocs.org/ https://github.com/miguelgrinberg/${PN}/ https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}