summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-26 21:53:51 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-26 21:55:08 +0100
commit2061aae04d054cdabfcea55a92c5cdb55a8e10b9 (patch)
tree20782b8ee4f9e257de5b032bd198ecbb458a584a
parentdev-haskell/zlib-enum: update to EAPI=7 (diff)
downloadgentoo-2061aae04d054cdabfcea55a92c5cdb55a8e10b9.tar.gz
gentoo-2061aae04d054cdabfcea55a92c5cdb55a8e10b9.tar.bz2
gentoo-2061aae04d054cdabfcea55a92c5cdb55a8e10b9.zip
dev-haskell/bio: drop masked package
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/bio/Manifest1
-rw-r--r--dev-haskell/bio/bio-0.5.3-r2.ebuild64
-rw-r--r--dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch7
-rw-r--r--dev-haskell/bio/metadata.xml25
-rw-r--r--profiles/package.mask5
5 files changed, 0 insertions, 102 deletions
diff --git a/dev-haskell/bio/Manifest b/dev-haskell/bio/Manifest
deleted file mode 100644
index f9f2f698b894..000000000000
--- a/dev-haskell/bio/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST bio-0.5.3.tar.gz 103707 BLAKE2B 31c9e354ba33f20d6129a20d6272063498bfd4b4ea2cba9eddab8ede62ee894659eb5e6383ef022f5e003deab8bb3c92a98bcadae44db22e7b0346471cad5e4d SHA512 fbe09240a600abbcac952f52f05f28f9b305a1ae3def8b4144bd73bdb160acfbe5457086ef829057d5a73df1df5061668487b2ca5621df73628c8c4990b6b544
diff --git a/dev-haskell/bio/bio-0.5.3-r2.ebuild b/dev-haskell/bio/bio-0.5.3-r2.ebuild
deleted file mode 100644
index 9d49efd38d86..000000000000
--- a/dev-haskell/bio/bio-0.5.3-r2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.2.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit eutils haskell-cabal
-
-DESCRIPTION="A bioinformatics library"
-HOMEPAGE="http://biohaskell.org/Libraries/Bio"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-haskell/binary-0.4:=[profile?]
- dev-haskell/mtl:=[profile?]
- dev-haskell/old-time:=[profile?]
- dev-haskell/parallel:=[profile?]
- dev-haskell/parsec:=[profile?]
- >=dev-haskell/quickcheck-2:2=[profile?]
- dev-haskell/random:=[profile?]
- >=dev-haskell/tagsoup-0.8:=[profile?]
- >=dev-lang/ghc-6.10.4:="
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ghc-7.10.patch
-
- cabal_chdeps \
- 'binary >=0.4 && <0.5' 'binary >=0.4'
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag examples examples) \
- $(cabal_flag test test)
-}
-
-src_test() {
- dist/build/qc/qc || die
-}
-
-src_install() {
- haskell-cabal_src_install
-
- use test && rm "${ED}"/usr/bin/qc
- # many examples collide with dev-haskell/flower
- if use examples ; then
- pushd "${ED}"/usr/bin
- local example
- for example in *
- do
- mv "${example}" "${PN}-example-${example}"
- done
- popd
- fi
-}
diff --git a/dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch b/dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch
deleted file mode 100644
index d570d22917a7..000000000000
--- a/dev-haskell/bio/files/bio-0.5.3-ghc-7.10.patch
+++ /dev/null
@@ -1,7 +0,0 @@
-diff --git a/Bio/Alignment/Bowtie.hs b/Bio/Alignment/Bowtie.hs
-index 883b057..3e58f0e 100644
---- a/Bio/Alignment/Bowtie.hs
-+++ b/Bio/Alignment/Bowtie.hs
-@@ -1 +1,2 @@
-+{-# LANGUAGE FlexibleContexts #-}
- {-| This module provides a data type to represent an alignment
diff --git a/dev-haskell/bio/metadata.xml b/dev-haskell/bio/metadata.xml
deleted file mode 100644
index 8927e5f99073..000000000000
--- a/dev-haskell/bio/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- This is a collection of data structures and algorithms
- useful for building bioinformatics-related tools
- and utilities.
-
- Current list of features includes: a Sequence data type supporting
- protein and nucleotide sequences and conversion between them. As of version
- 0.4, different kinds of sequence have different types. Support for quality
- data, reading and writing Fasta formatted files, reading TwoBit and
- phd formats, and Roche/454 SFF files. Rudimentary (i.e. unoptimized) support
- for doing alignments - including dynamic adjustment of scores based on sequence quality.
- Also Blast output parsing. Partly implemented single linkage clustering, and
- multiple alignment. Reading Gene Ontology (GO) annotations (GOA) and
- definitions\/hierarchy.
-
- The Darcs repository is at: &lt;http://malde.org/~ketil/biohaskell/biolib&gt;.
- </longdescription>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 9e82fe40d47a..ac73a4255de2 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -675,11 +675,6 @@ dev-haskell/cryptocipher
# Dead upstream. Removal in 30 days
net-mail/maildirtree
-# Sergei Trofimovich <slyfox@gentoo.org> (2020-08-27)
-# Abandoned upstream.
-# Does not compile against ghc-8.8. Removal in 30 days.
-dev-haskell/bio
-
# Piotr Karbowski <slashbeast@gentoo.org> (2020-08-28)
# Temporary mask due to multiple reports of segfaults at startup, bug #739056
=x11-base/xorg-server-1.20.9