summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-08-25 07:44:16 +0200
committerHans de Graaff <graaff@gentoo.org>2015-08-25 07:50:22 +0200
commit20dfd1fdbea19b2b2b0b1e2552bc2e4376401ed2 (patch)
tree27e1d5974a14017b3c61a60f57bd2eab472fd787
parentdev-qt/qtdeclarative: Stable for HPPA (bug #543326). (diff)
downloadgentoo-20dfd1fdbea19b2b2b0b1e2552bc2e4376401ed2.tar.gz
gentoo-20dfd1fdbea19b2b2b0b1e2552bc2e4376401ed2.tar.bz2
gentoo-20dfd1fdbea19b2b2b0b1e2552bc2e4376401ed2.zip
dev-ruby/activesupport: version bump
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-4.2.4.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index cc3c4492fd9a..68e0401554ad 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -5,3 +5,4 @@ DIST rails-4.1.12.tgz 3726629 SHA256 141e5554d854b3eb12246e748e0080057766d5006b4
DIST rails-4.1.13.tgz 3726822 SHA256 94112f3398c5ffd5e53ce959969c133b35386ade0a9d845eaead4237a5546335 SHA512 8fef27cfbe898fc691562d9a6d543816c3e5c08c4c114b01115024e573b6d49568bca13da9d4574cfe0b76cc778c734e4a24def7047c90fb1c6d1c78553bcee3 WHIRLPOOL 321e60e7f51026e6c79c9f1cf128b349dbab08ed17d8f20fb034f1317c8498edcdaebf166fa30995abc80c6a4cd691408b3b4046adf11086899cd995e94c7d0a
DIST rails-4.2.2.tgz 4149494 SHA256 e8a0b1f96e2bf0bf24b2f28a5b5eabed7886b056119bd51c01ed451db4f35932 SHA512 707fddfcabf960ebccac9aa8c88067b1adedee341eed80a60c07044145f67047a91eb6d52b05c18d0693f0e575ec51b494b3095df755067f7cacd3a62275189f WHIRLPOOL 6b9296edbcaf95c20adf2981f877cf0b6febc4e2f33873826ab36ff0cdff68308c8e748bd9fdfb56f1d4e72c1588e25b826103ab7df9d74dd0e4e756d61d648a
DIST rails-4.2.3.tgz 4160455 SHA256 79956b73a496d4e409d7bc639980049ba58e1a2976c6cd3beaffc596e913f337 SHA512 6e6cd821764b7b9f86cefc5a075ec590711d9f465a2692a6ee4b403ced8ff262bf5723da2b7061b7b9a450f3af1c99f781f1230844ede201f5ad828c34d9c9ea WHIRLPOOL 351a2cd4571ae0ad0e39304267f0bcfd5fd544bc38bec75beaed50ebe802d0215660e31edf9ac00cb5acb6ad1c0b32947fa7b161d8ecbc490006ecc51f94fd4c
+DIST rails-4.2.4.tgz 4166672 SHA256 cc6618eaa2c640932e803dfac6bbde135fad3a6874dfc4e547712ec9182241d4 SHA512 7ce9fabdd302ce8fd1077147e6e45926ba12aa4177d2e1b78775a8fb3b80420f09c4076ecf726f410610a38187f2a8abeaff3d2b1de25e8386685db998bd2308 WHIRLPOOL 0e7bce539ba3c20f5c7de965af478505d76ebad0fd42498b13cb9a9c576304ad9694dd218bc6debf7a02cb437bebc5f75425c104956d32f4afefd1cc2c020d8d
diff --git a/dev-ruby/activesupport/activesupport-4.2.4.ebuild b/dev-ruby/activesupport/activesupport-4.2.4.ebuild
new file mode 100644
index 000000000000..cc47c8d8c4b8
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-4.2.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/i18n-0.7:0.7
+ >=dev-ruby/json-1.7.7:0
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5
+ >=dev-ruby/thread_safe-0.3.4:0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/libxml-2.0.0
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid test that seems to be broken by lack of DST.
+ sed -i -e '369 s:^:#:' test/core_ext/string_ext_test.rb || die
+
+ # Avoid test that fails with Minitest 5.4 since that already defines
+ # a string E in its TestCase.
+ rm test/core_ext/marshal_test.rb || die
+ sed -i -e '/test_const_missing_in_anonymous_modules/askip "gentoo minitest"' test/dependencies_test.rb || die
+}