summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-13 00:44:32 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-13 00:47:16 -0600
commit219a5df7a554ff09be3289d44cbf46871d315cc4 (patch)
tree8e35d790ea3f98511a65374a4d122eec771e1f65
parentdev-python/llfuse: version bump to 1.3.5 (diff)
downloadgentoo-219a5df7a554ff09be3289d44cbf46871d315cc4.tar.gz
gentoo-219a5df7a554ff09be3289d44cbf46871d315cc4.tar.bz2
gentoo-219a5df7a554ff09be3289d44cbf46871d315cc4.zip
dev-python/apsw: version bump to 3.25.2_p1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.25.2_p1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 69ef89a05740..6966e81f630e 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -2,3 +2,4 @@ DIST apsw-3.19.3_p1.zip 678966 BLAKE2B 1726a50024369831fe0ee442676adc4415c7b71e5
DIST apsw-3.21.0_p1.zip 680827 BLAKE2B 8fceb2d782f3bbaba28f26904ed11281be7e2be351d78c41d39d2941ad45304bd7e62cfbbc9134e21b1ffad4f7b7d1373a2866d6cbb61345c263502b23fb018a SHA512 c2009d243765532e27220478d1164f97201afbd2b1de1e4090b4f35b63c83d0a82d2bdfe14c6625858867633995d3d8eef91f17ecbbd915f99e5a4a4edfa7b61
DIST apsw-3.22.0_p1.zip 680988 BLAKE2B eda9b217ee8d23b5fc80e5d240b11493f8ef82208f3b694619ba168f4bd640691cdf253d9315fb0f2d178fcce2bd1ed4028d75488f5fb3c0db95c518fec8f71d SHA512 c82de649a9245283dd0acc37700270c6c4dde1995cdc88bf7afb7cb3913a6f1a4a7a077e80eeb70cccf2fcb058406b610c9f05f478c6dc9ee8f7ff9cde7c7395
DIST apsw-3.23.1_p1.zip 682088 BLAKE2B 0b1c492c68522f9d3d1c693370b3b1562de0e4521f3a3de0988c40ddcf717f79201555228c16b9b9870db47582bf2b774f7e9ce0ddea4e19c3d132bbf2322551 SHA512 8f3bc9e619ed8671a0804e6d3c9ecf34d452a4e6fe540fb23bfb6ae67578971013300ad6cdffe3be2fc1197c4fd3af096802aef5994cbe53253467133363ac62
+DIST apsw-3.25.2_p1.zip 682975 BLAKE2B f9f471378cddd7da1c06158b7a041d9377da4d4123846318c0cfc24167734bc1813f667e64c4c6bf643c6a618c9cabf58301dfbaad0998082d764212ea369fff SHA512 073b2fe9170fb00ac6f2ba52eb638d64d79875ba74b09f0307fa2c075e714bb91465fd2edd46341dac5cedc0bee0a1099888b6c1cee706fc04fa6b9ad99c47d7
diff --git a/dev-python/apsw/apsw-3.25.2_p1.ebuild b/dev-python/apsw/apsw-3.25.2_p1.ebuild
new file mode 100644
index 000000000000..081a446bc22a
--- /dev/null
+++ b/dev-python/apsw/apsw-3.25.2_p1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="https://github.com/rogerbinns/apsw/"
+SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-db/sqlite-${PV%_p*}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )
+
+python_compile() {
+ python_is_python3 || append-cflags -fno-strict-aliasing
+ distutils-r1_python_compile --enable=load_extension
+}
+
+python_test() {
+ "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
+ "${PYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}