summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-08 23:55:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-09 10:05:21 +0100
commit2239cf564080b5f7c0897e131dffe06ec40ce602 (patch)
treeaff004f35f51d966b0b5bf65b9f47795a164d91e
parentdev-ros/genpy: Bump to 0.6.5 (diff)
downloadgentoo-2239cf564080b5f7c0897e131dffe06ec40ce602.tar.gz
gentoo-2239cf564080b5f7c0897e131dffe06ec40ce602.tar.bz2
gentoo-2239cf564080b5f7c0897e131dffe06ec40ce602.zip
dev-ml/jsonm: Bump to 1.0.1
Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--dev-ml/jsonm/Manifest1
-rw-r--r--dev-ml/jsonm/jsonm-1.0.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/jsonm/Manifest b/dev-ml/jsonm/Manifest
index d4c6301d6769..0e2d4ed5ff78 100644
--- a/dev-ml/jsonm/Manifest
+++ b/dev-ml/jsonm/Manifest
@@ -1 +1,2 @@
DIST jsonm-1.0.0.tbz 21549 SHA256 c258ea713d25445341774cf085fa0cf7d2a570c34d5a8d84a49716939ab174ec SHA512 3b0a332a0f3ddcf21ed9ca33fe3bec97f69e4fa3b6f85728965efc0f8f8c6b3187d0d71138c97a568783d6fb9f2aaf6edcd83061350cad13a9378e3c92c80b6e WHIRLPOOL 2b7cf9afa6cd71a5b180909b245ba6408f4a163a048271cf91da47f7bfb25de3a657351c5414562f5e0e6872c9dd77de74f13b9b2b0b5e536693b756934a24f6
+DIST jsonm-1.0.1.tbz 21608 SHA256 3c09562ed43b617d8b6d9522a249ff770228e7d6de9f9508b72e84d52b6be684 SHA512 e86e225073b429f71063af14ad39b87498609db6a122b39e1a739c5b77fcde487bf6b17235b2f9742b7d22aca0f6d475fdba1b0bab2a6329cf7e681fe43d31a6 WHIRLPOOL 752e40befd1d249dd9a44501cd352fecf39cf327c0e232e3d0d9b4663a107c27e7ddc77b8428d5ba4438002c758d1f724fe2df429c0760488e19fd8649ae6f87
diff --git a/dev-ml/jsonm/jsonm-1.0.1.ebuild b/dev-ml/jsonm/jsonm-1.0.1.ebuild
new file mode 100644
index 000000000000..3f0cda56cc22
--- /dev/null
+++ b/dev-ml/jsonm/jsonm-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Non-blocking streaming JSON codec for OCaml"
+HOMEPAGE="http://erratique.ch/software/jsonm"
+SRC_URI="http://erratique.ch/software/jsonm/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/uutf-1.0.0:=
+ dev-lang/ocaml:=
+ dev-ml/uchar:="
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+DOCS=( CHANGES README )
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs="$(echo _build/src/${PN}.cm{x,xa,xs,ti} _build/src/${PN}.a)"
+ ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
+ newbin _build/test/jsontrip.native jsontrip
+ dodoc CHANGES.md TODO.md README.md
+}