summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-04 14:31:39 +0000
committerSam James <sam@gentoo.org>2020-12-04 14:35:12 +0000
commit22f11a2a57cdb34654c564f03756ae557b2d82ae (patch)
tree4829c0123ab0d1edb9ba295f182afd45140bad7b
parentgames-emulation/dosbox-staging: 0.76.0 bump (diff)
downloadgentoo-22f11a2a57cdb34654c564f03756ae557b2d82ae.tar.gz
gentoo-22f11a2a57cdb34654c564f03756ae557b2d82ae.tar.bz2
gentoo-22f11a2a57cdb34654c564f03756ae557b2d82ae.zip
app-doc/cppman: bump to 0.5.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-doc/cppman/Manifest1
-rw-r--r--app-doc/cppman/cppman-0.5.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-doc/cppman/Manifest b/app-doc/cppman/Manifest
index 7e0b0cdd148e..c41ed953a2ff 100644
--- a/app-doc/cppman/Manifest
+++ b/app-doc/cppman/Manifest
@@ -1,2 +1,3 @@
DIST cppman-0.4.8.tar.gz 3185978 BLAKE2B 9f662874eb6b6540e02a2b371fa47e53e0893239fbfcc65421fa5c7c4bc5f88c4cfd2facf08deb13606f5cf7c895a1a07e119e1c15bbc98b95af5f8056c6a5e8 SHA512 f5b93774988dad592b31670d6c21718bd034e4e94858982e1756e8db89779d12001fd786ba629211b038b173b7b507382277a3db7fb35363dba28cd029e69a7d
DIST cppman-0.4.9.tar.gz 3237707 BLAKE2B 23068f8896dd4f9fa3ab86e8e3ddb7de5190af4f59f3cf283537c6ce8c3df60c5deab4972be750464121eeb1ebbde93e30c313869d5fb92e1d784d1294b1d842 SHA512 49957e9c9dcf82a85558d47325912e689ed7786f745015215b32e6f86b97878af6edcb265655674191992ba16171fdbf2220ee43d8c90a0d5eb37f1fb584c3ce
+DIST cppman-0.5.1.tar.gz 3596049 BLAKE2B 0189da1413720c00c89a0685b83231aaf0c54e19c84ede164e892e7f8855b7b1ceb1baee11866fd99d150e9c031ccea88bcecdda816fb8e53d58b918a000e04a SHA512 3248d9795d3a379f13e43d5e0753f62a0412dcf3760b8dec6a176f08cb71c4983065c7d27eb15ffed4cc77264e66a3f7d9fe5757a8c7a582741751bcfd1b2fd6
diff --git a/app-doc/cppman/cppman-0.5.1.ebuild b/app-doc/cppman/cppman-0.5.1.ebuild
new file mode 100644
index 000000000000..dcf11a608c3d
--- /dev/null
+++ b/app-doc/cppman/cppman-0.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+
+DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
+HOMEPAGE="https://github.com/aitjcize/cppman"
+SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+RDEPEND="
+ sys-apps/groff
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/html5lib[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ default
+
+ # Don't allow setup.py to install documentation directly
+ sed -i '\:share/doc/cppman:d' setup.py || die "sed failed"
+}