summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-10-15 12:17:17 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-15 14:31:53 +0200
commit233380e49f71c727d8878d6fb8215797b81ca905 (patch)
tree277f3b76f44355815126648d1932692a5d255a00
parentapp-vim/showmarks: clean up old. (diff)
downloadgentoo-233380e49f71c727d8878d6fb8215797b81ca905.tar.gz
gentoo-233380e49f71c727d8878d6fb8215797b81ca905.tar.bz2
gentoo-233380e49f71c727d8878d6fb8215797b81ca905.zip
app-vim/perlomni: Stable for amd64. Mark stable for the remaining arches using the ALLARCHES policy.
Package-Manager: portage-2.3.0
-rw-r--r--app-vim/perlomni/perlomni-2.5.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/app-vim/perlomni/perlomni-2.5.ebuild b/app-vim/perlomni/perlomni-2.5.ebuild
index 28b0746ba030..c576dc35e0b3 100644
--- a/app-vim/perlomni/perlomni-2.5.ebuild
+++ b/app-vim/perlomni/perlomni-2.5.ebuild
@@ -6,23 +6,31 @@ EAPI=6
inherit vim-plugin
-DESCRIPTION="vim plugin: Perl omni completion"
+DESCRIPTION="vim plugin: a vim plugin with Perl omni completion functions"
HOMEPAGE="https://github.com/c9s/perlomni.vim"
SRC_URI="https://github.com/c9s/${PN}.vim/archive/v${PV}.zip -> ${P}.zip"
LICENSE="vim.org"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ppc ppc64 x86"
DEPEND="
app-arch/unzip
dev-lang/perl"
+RDEPEND="${DEPEND}"
+
S="${WORKDIR}/${PN}.vim-${PV}"
src_prepare() {
default
- rm -v Makefile config.mk README.mkd README.mkd.old win32-install.bat TODO || die
+ local CLEANUP=(
+ Makefile
+ config.mk
+ README.mkd
+ README.mkd.old
+ win32-install.bat
+ TODO
+ )
+ rm -v "${CLEANUP[@]}" || die
}
-src_compile() {
- :;
-}
+src_compile() { :; }