summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-11-19 06:39:46 +0100
committerHans de Graaff <graaff@gentoo.org>2018-11-19 06:39:46 +0100
commit2476c812795d8a346562a8d576dfea2188745ec4 (patch)
treec3804ddf96e90a2ccb3dca3051cca654887100a4
parentmedia-tv/kodi: Experimental Python 3 support in -9999 (diff)
downloadgentoo-2476c812795d8a346562a8d576dfea2188745ec4.tar.gz
gentoo-2476c812795d8a346562a8d576dfea2188745ec4.tar.bz2
gentoo-2476c812795d8a346562a8d576dfea2188745ec4.zip
dev-ruby/asciidoctor-diagram: add 1.5.11
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-ruby/asciidoctor-diagram/Manifest1
-rw-r--r--dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.11.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor-diagram/Manifest b/dev-ruby/asciidoctor-diagram/Manifest
index eb0920f1329c..69e62e1a0083 100644
--- a/dev-ruby/asciidoctor-diagram/Manifest
+++ b/dev-ruby/asciidoctor-diagram/Manifest
@@ -1,2 +1,3 @@
DIST asciidoctor-diagram-1.5.10.tar.gz 10441267 BLAKE2B e5adfa51ecdf966d471c9adb8ee6a99e5a208b4934646a1f0d672fd29b69cf59eefdee90444b0b99ff3c91172c99b9f41768ad7f4edf7ec203416c47b46d7e88 SHA512 fcf76d71d0b9d58dc5a01aa484faa663f636ff36f534c43621a71702032d1f49a04189d0ffaff8b0fdc2f189d54ce7392f74e1b0f29128fc3180e48d35bed5b1
+DIST asciidoctor-diagram-1.5.11.tar.gz 10441331 BLAKE2B ac1df387a4a55701fa86b336b88f3f389cbe20dcb806baf744fe041db24035f7238124677685e1c79bc1df3747c1fddb6abdfae7a981bf0703897ad868aedb04 SHA512 f3e46b0befa6a104f5dc4732bfaca006bd52be4c919bebcea4692037ed444cfdc1c73a1ae00d08989847e6ce1cd42d8d3ca3964dbd5817b22c7332bb895a6b5c
DIST asciidoctor-diagram-1.5.9.tar.gz 10250161 BLAKE2B ebeb184259042a9088c5a8f6c5afc86a69f6fcea62964ac2f571f21b6b2b382cdf2cad8abc1e99ca781b4663da956982f1a5d418126089b17bac0e68bdce0fea SHA512 b25f5c2b8ddfc2b9bdc26ef47b5a2ae8d28992ac26f70ccc4c9046a45e9338b5ed2b82cccb0f01dd44155e043b620410b468ef6b12dfe03ae20a67e4d109be05
diff --git a/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.11.ebuild b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.11.ebuild
new file mode 100644
index 000000000000..c3548454fb5f
--- /dev/null
+++ b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc LICENSE.txt README.adoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A set of Asciidoctor extensions that enable you to add diagrams"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor-diagram"
+SRC_URI="https://github.com/asciidoctor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/asciidoctor-1.5*"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/c.formatter/ s:^:#:' spec/test_helper.rb || die
+
+ # Avoid specs for unpackaged tools
+ rm -f spec/{a2s,blockdiag,erd,mermaid,msc,shaape,svgbob,syntrax,umlet,vega,wavedrom}_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}