summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-11-05 10:23:11 +0100
committerJeroen Roovers <jer@gentoo.org>2016-11-05 10:23:11 +0100
commit24f0f3ff5914b17c54a7282dbbdd289b68d9c8ad (patch)
treeb41aab579d8682364a65d17b8f0eaf30a28e8e62
parentnet-analyzer/netperf: Revert going straight to stable. (diff)
downloadgentoo-24f0f3ff5914b17c54a7282dbbdd289b68d9c8ad.tar.gz
gentoo-24f0f3ff5914b17c54a7282dbbdd289b68d9c8ad.tar.bz2
gentoo-24f0f3ff5914b17c54a7282dbbdd289b68d9c8ad.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.2
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.11.04.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 29a5d1980914..380b430370a5 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b
DIST youtube-dl-2016.09.19.tar.gz 2395739 SHA256 276637e83525778a83d0457f6b9fbc29d6109bc8366d43125432ce835d28545e SHA512 a8fb1ce054e25180eab3969c898d976dec157901931b66cddde0fecd55ef322e64c13a70d50de945849cbc4ccbf8be0aede845cbb8ea390bba34f51fec0533bf WHIRLPOOL e58d38e49d58b86d8eb25b40427046955e011bf57b0862c433ebe459c0268905bff67188c03bb612593d15b3d1f3408a95b510ad6f863d0144ee4307ed012aba
DIST youtube-dl-2016.10.26.tar.gz 2446645 SHA256 df9f9848198ef225bc351db016d54843fb93252704a786e7e34418f60617b1a5 SHA512 0630774fa0f91fce7aaa7ecae44805bc75f171f0da6eacf943d01df11bedc4797fa9c48e859832b24fbc98dee1c3dce99e168a7c3a8ccd9240a05153b31237e6 WHIRLPOOL c79b3b4e193683625fb9aae1e36a9719bcc8208179a5dae5e30bedfecaaa1049cf9f7ea4633f0118f93a28d5a6449da3366e8eaffcaa78cc3a0b5fcce3485425
DIST youtube-dl-2016.11.02.tar.gz 2457622 SHA256 97777924c3df763d3f2259c9a7f227a01e787ccd452be198191a4a848a7632d7 SHA512 54501a153dad0523ab4df4120169b9bb9e0ae61c82eb9d1c126ced06c3f853604ef9104812cf839ef348b04c04d016798cac9e15cff45b4eba1cff09096d6d5c WHIRLPOOL 022448b9b9ed79ad703a01d5caaa66caa2e64dd4f7fd99fc70d8cd834ab6fb2234f15c4196c9fe1b2d504acd846814d37de3754feaeaab4f2aedab5fcad441e1
+DIST youtube-dl-2016.11.04.tar.gz 2463253 SHA256 9622b29b81587278a00e39e4206e7c52555d240cbbb44242f237660169e8d531 SHA512 063954b3980e5f946eb54c27bfd7593f1f4076d452fb8edf495bee91db66d5a31efc8038dbbdd39d5b11c3e144104e6dc858dcff678bd9dba7ebbafd134a30ca WHIRLPOOL a3176dad02e988f8e315901be2d93b57f3c437b9fc7b91f056f7db3a7874dfe14e2b0354c2570b5996f9f67970cdad2b9fa888964a00ac2b5160dbd9327f5aa9
diff --git a/net-misc/youtube-dl/youtube-dl-2016.11.04.ebuild b/net-misc/youtube-dl/youtube-dl-2016.11.04.ebuild
new file mode 100644
index 000000000000..b704f645876b
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.11.04.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}