summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <meurerbernardo@gmail.com>2019-08-03 20:33:09 -0700
committerAaron Bauman <bman@gentoo.org>2019-08-08 20:12:32 -0400
commit264467e31b7139e731ccbf277812b7652e96f6c6 (patch)
tree5bf11c935cea1da5e897018c4fa62a8d260288c1
parentprofiles/arch/ia64/package.use.mask: sys-apps/rng-tools -jitterentropy (diff)
downloadgentoo-264467e31b7139e731ccbf277812b7652e96f6c6.tar.gz
gentoo-264467e31b7139e731ccbf277812b7652e96f6c6.tar.bz2
gentoo-264467e31b7139e731ccbf277812b7652e96f6c6.zip
gui-apps/grim: New package (1.2.0, 9999)
Closes: https://bugs.gentoo.org/684712 Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Closes: https://github.com/gentoo/gentoo/pull/12613 Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--gui-apps/grim/Manifest1
-rw-r--r--gui-apps/grim/grim-1.2.0.ebuild45
-rw-r--r--gui-apps/grim/grim-9999.ebuild45
-rw-r--r--gui-apps/grim/metadata.xml24
4 files changed, 115 insertions, 0 deletions
diff --git a/gui-apps/grim/Manifest b/gui-apps/grim/Manifest
new file mode 100644
index 000000000000..3b6273b83c4e
--- /dev/null
+++ b/gui-apps/grim/Manifest
@@ -0,0 +1 @@
+DIST grim-1.2.0.tar.gz 14445 BLAKE2B e833afe5e57768e269ece0d7f99653810424449840867a37f02db4645a0dedd7829241d24a39ca00e844505ab5d2408891aac325e7f6ddd2011884fee240b44b SHA512 d58e392f00b93e031fd46a9e0175aaa5c3ce4fafb2afa3cc97ff28a9f77fc5583774f6ddf86295262749c00dd7c4e98c6041588bfa6fd70319ddfce6b903414e
diff --git a/gui-apps/grim/grim-1.2.0.ebuild b/gui-apps/grim/grim-1.2.0.ebuild
new file mode 100644
index 000000000000..c8c932c13aa2
--- /dev/null
+++ b/gui-apps/grim/grim-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Grab images from a Wayland compositor."
+HOMEPAGE="https://github.com/emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ jpeg? ( virtual/jpeg )
+ x11-libs/cairo
+"
+RDEPEND="
+ ${DEPEND}
+"
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/grim/grim-9999.ebuild b/gui-apps/grim/grim-9999.ebuild
new file mode 100644
index 000000000000..c8c932c13aa2
--- /dev/null
+++ b/gui-apps/grim/grim-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Grab images from a Wayland compositor."
+HOMEPAGE="https://github.com/emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ jpeg? ( virtual/jpeg )
+ x11-libs/cairo
+"
+RDEPEND="
+ ${DEPEND}
+"
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/grim/metadata.xml b/gui-apps/grim/metadata.xml
new file mode 100644
index 000000000000..24e0317c3dfa
--- /dev/null
+++ b/gui-apps/grim/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Grab images from a Wayland compositor.
+ </longdescription>
+ <use>
+ <flag name="jpeg">Enable JPEG support.</flag>
+ <flag name="man">Generate and install man pages.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">emersion/grim</remote-id>
+ <bugs-to>https://github.com/emersion/grim/issues</bugs-to>
+ <changelog>https://github.com/emersion/grim/releases</changelog>
+ </upstream>
+</pkgmetadata>