summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-07-31 11:01:54 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-07-31 11:01:54 -0400
commit26b53a37ef3782e46354355ecdcbcdc1b59ddc3d (patch)
tree38b7e5112946ca40b85f4aa8c6406b6719519e9a
parentdev-python/pillow: EAPI 7 (diff)
downloadgentoo-26b53a37ef3782e46354355ecdcbcdc1b59ddc3d.tar.gz
gentoo-26b53a37ef3782e46354355ecdcbcdc1b59ddc3d.tar.bz2
gentoo-26b53a37ef3782e46354355ecdcbcdc1b59ddc3d.zip
dev-python/pillow: fix incompatibility with pytest-relaxed
When installed, pytest-relaxed would make our tests fail. Disable it. Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--dev-python/pillow/pillow-5.2.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/pillow/pillow-5.2.0.ebuild b/dev-python/pillow/pillow-5.2.0.ebuild
index 5d2590a0a858..b4f435d0425c 100644
--- a/dev-python/pillow/pillow-5.2.0.ebuild
+++ b/dev-python/pillow/pillow-5.2.0.ebuild
@@ -83,7 +83,8 @@ python_compile_all() {
python_test() {
"${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
- virtx pytest -vx Tests/test_*.py
+ # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
+ virtx pytest -vx Tests/test_*.py -p no:relaxed
}
python_install() {