summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2018-01-21 16:00:15 +0100
committerAaron Bauman <bman@gentoo.org>2018-03-26 20:27:18 -0400
commit2a3133513247eacd8e28d558adc5def4d38e8a1b (patch)
tree0d59d6ab71cc32530547777227be1d226f48ca13
parentlxde-base/lxappearance: Remove old (diff)
downloadgentoo-2a3133513247eacd8e28d558adc5def4d38e8a1b.tar.gz
gentoo-2a3133513247eacd8e28d558adc5def4d38e8a1b.tar.bz2
gentoo-2a3133513247eacd8e28d558adc5def4d38e8a1b.zip
lxde-base/lxrandr: Add locale handling
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6921
-rw-r--r--lxde-base/lxrandr/lxrandr-0.3.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/lxde-base/lxrandr/lxrandr-0.3.1-r1.ebuild b/lxde-base/lxrandr/lxrandr-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..8ade7e9fef09
--- /dev/null
+++ b/lxde-base/lxrandr/lxrandr-0.3.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="af ar ast be bg bn_IN bn ca cs da de el en_GB es et eu fa fi fo
+fr frp gl he hr hu id is ja kk ko lg lt ml ms nb nl nn pa pl ps pt_BR pt
+ro ru sk sl sr@latin sr sv te th tr tt_RU ug uk ur_PK ur vi zh_CN zh_TW"
+
+PLOCALE_BACKUP="en_GB"
+
+inherit l10n
+
+DESCRIPTION="LXDE GUI interface to RandR extention"
+HOMEPAGE="http://lxde.org/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXrandr
+ x11-apps/xrandr"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0"
+
+src_prepare() {
+ default
+ export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
+ l10n_get_locales > po/LINGUAS || die
+}