summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-04 00:31:45 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-04 01:05:50 +0300
commit2cd7311fb41e95132c973528d161cf045562753a (patch)
treea18d7cf8b2d3e46ed23ab19264289f972c58e541
parentprofiles/arch/x86: Add app-emulation/nemu[spice] mask (diff)
downloadgentoo-2cd7311fb41e95132c973528d161cf045562753a.tar.gz
gentoo-2cd7311fb41e95132c973528d161cf045562753a.tar.bz2
gentoo-2cd7311fb41e95132c973528d161cf045562753a.zip
app-emulation/nemu: Version bump (v2.2.0)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--app-emulation/nemu/Manifest1
-rw-r--r--app-emulation/nemu/metadata.xml2
-rw-r--r--app-emulation/nemu/nemu-2.2.0.ebuild73
3 files changed, 76 insertions, 0 deletions
diff --git a/app-emulation/nemu/Manifest b/app-emulation/nemu/Manifest
index f5a1065c9607..3e18fd604fb2 100644
--- a/app-emulation/nemu/Manifest
+++ b/app-emulation/nemu/Manifest
@@ -1,2 +1,3 @@
DIST nemu-2.0.0.tar.gz 85769 BLAKE2B daadbd5925d56d3747b59a3a8f28ceeeb24a674e57f003cf07c67c24dc0ed73f024d35e2f02836d89c7568b7ac51bfc3c6131afb4864febdd6ac6f86a827bfee SHA512 74c489e35b96699fcc5f9cabdbe4445c1cdad5b06c2a18928e2270e169b76e009463177990c4f4d80b160e06118b0b4e87209132cc0ae0ee3d77e2d811865f5a
DIST nemu-2.1.0.tar.gz 89117 BLAKE2B a44bf67990d79af0b73caf077266c4775f302ffc81d2394993da45870a72f462d487a92d63abdbe875c382d11b8d691f446a5e0b7270355770838ea86328fb1d SHA512 7e655227e22f5e2dd5ec1f77ef1635f1aaab2e57e417fb33d83d35cc67d7b802c35fa9174cf4282287213a1a825714743773260b96b452a382a8248fbef238bf
+DIST nemu-2.2.0.tar.gz 94061 BLAKE2B 95304e8834f1d5c1e31065728363de5d797ae79554733dd3fecd90388b2766bc8907acfeded36676272967153eed5a7f30baba9ef2384fca67d19f3519461fa6 SHA512 2f427a560ea5ac4112b7d5cdd8524366521ca3d185676a4faa9bc480331c3381b7a362aed20025dc1acc0f576f07fb627b03137e1998926761a169c5be0eaf97
diff --git a/app-emulation/nemu/metadata.xml b/app-emulation/nemu/metadata.xml
index ad75c6dc879c..b2ce9edb9146 100644
--- a/app-emulation/nemu/metadata.xml
+++ b/app-emulation/nemu/metadata.xml
@@ -8,6 +8,8 @@
<use>
<flag name="vnc-client">Adds support for external VNC client</flag>
<flag name="savevm">Adds support for QEMU savevm snapshots (experimental, QEMU must be patched)</flag>
+ <flag name="spice">Adds Spice protocol support</flag>
<flag name="ovf">Adds support for OVA/OVF import</flag>
+ <flag name="network-map">Adds possibility of exporting network map to SVG</flag>
</use>
</pkgmetadata>
diff --git a/app-emulation/nemu/nemu-2.2.0.ebuild b/app-emulation/nemu/nemu-2.2.0.ebuild
new file mode 100644
index 000000000000..7b885f4f50c6
--- /dev/null
+++ b/app-emulation/nemu/nemu-2.2.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils linux-info
+
+DESCRIPTION="ncurses interface for QEMU"
+HOMEPAGE="https://lib.void.so/nemu/ https://bitbucket.org/PascalRD/nemu/"
+SRC_URI="https://lib.void.so/src/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug network-map +ovf savevm spice +vnc-client"
+
+RDEPEND="app-emulation/qemu[vnc,virtfs,spice?]
+ dev-db/sqlite:3=
+ sys-libs/ncurses:0=[unicode]
+ virtual/libusb:1
+ virtual/libudev:=
+ network-map? ( media-gfx/graphviz )
+ ovf? (
+
+ dev-libs/libxml2:2
+ app-arch/libarchive
+
+ )
+ vnc-client? ( net-misc/tigervnc )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="sys-devel/gettext"
+
+pkg_pretend() {
+ if use kernel_linux; then
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel"
+ else
+ CONFIG_CHECK="~VETH ~MACVTAP"
+ ERROR_VETH="You will need the Virtual ethernet pair device driver compiled"
+ ERROR_VETH+=" into your kernel or loaded as a module to use the"
+ ERROR_VETH+=" local network settings feature."
+ ERROR_MACVTAP="You will also need support for MAC-VLAN based tap driver."
+
+ check_extra_config
+ fi
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DNM_DEBUG=$(usex debug)
+ -DNM_WITH_NETWORK_MAP=$(usex network-map)
+ -DNM_WITH_OVF_SUPPORT=$(usex ovf)
+ -DNM_SAVEVM_SNAPSHOTS=$(usex savevm)
+ -DNM_WITH_SPICE=$(usex spice)
+ -DNM_WITH_VNC_CLIENT=$(usex vnc-client)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "For non-root usage execute script:"
+ elog "/usr/share/nemu/scripts/setup_nemu_nonroot.sh linux <username>"
+ elog "and add udev rule:"
+ elog "cp /usr/share/nemu/scripts/42-net-macvtap-perm.rules /lib/udev/rules.d"
+ if use savevm; then
+ elog ""
+ elog "QEMU must be patched with qemu-qmp-savevm-VERSION.patch"
+ elog "Get this patch from nEMU repository"
+ fi
+}