summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-28 11:51:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-28 12:56:45 +0200
commit2cf0b405625c3838e1266a91ed08ce18dc65cc94 (patch)
tree2174dce66c1fbe1c5f064d5e9f7039d29e142cd8
parentnet-analyzer/snort: Bump #587194 (diff)
downloadgentoo-2cf0b405625c3838e1266a91ed08ce18dc65cc94.tar.gz
gentoo-2cf0b405625c3838e1266a91ed08ce18dc65cc94.tar.bz2
gentoo-2cf0b405625c3838e1266a91ed08ce18dc65cc94.zip
app-text/lcdf-typetools: bump to 2.106
Package-Manager: portage-2.3.0
-rw-r--r--app-text/lcdf-typetools/Manifest1
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.106.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-text/lcdf-typetools/Manifest b/app-text/lcdf-typetools/Manifest
index ba8336a87789..d3fb63473f33 100644
--- a/app-text/lcdf-typetools/Manifest
+++ b/app-text/lcdf-typetools/Manifest
@@ -1,3 +1,4 @@
DIST lcdf-typetools-2.104.tar.gz 636875 SHA256 d7985458ead0850cb9549ff1d619ffc18da5d7be892be5e1fce6048d510f0fff SHA512 0d41386787aa18e5a7a85158ebba2046480c2320cbdfeaad75092962335f8f97a0ceede1aa301197d6c971bd6be729960c636fb14a8ce21e4c7f3f0e57257388 WHIRLPOOL 327e88a89cedb4a66fe93878c68dff11cb2b1d8d189eb3107f1782e67a70444ccee2b1ee6362f189441695f5e02a334311f9458a4a3f1d752fe22d863a2f3d20
DIST lcdf-typetools-2.105.tar.gz 640159 SHA256 c8b6a58e2f8f61ff3c21fd61452032c83938c91fde00f302b8f9391b16c6b63a SHA512 52670a7faca7da175819420c68aa9b34d3d488ed5d25f13e9d0930e9442857c481575c89a379183c9cd4a1b2a0786bcd8ffe33682e284b8f6e12ca917bb97538 WHIRLPOOL 729766b968ad48495edb952f89d13cb7e59c37b46606f12d0a7748feb8e722fb67e3f981a63c64fb1b81129d8059a985bf08a2978f33e0586aa3f8ab95f034f0
+DIST lcdf-typetools-2.106.tar.gz 643503 SHA256 503c3869f73a392ae0ba41e0fc4f7672e70e2d66e8a81f3bb183f495183fa967 SHA512 039215132585214e6518864161885f7a06f08f8b36b002a961b1d83182e388b31eb034eaa4466ba56a2af52e1cfb202e88f004be17c22df1343f94481e3114cf WHIRLPOOL 6ec074348f3a1f17d06b7f70f5b170d70b63055d81556ba8c2c14c50e7be4f0070f3ad685a1624a8e10a78db931cd798f7656a08b7fa0c324d663f4d0fcfad51
DIST lcdf-typetools-2.97.tar.gz 616431 SHA256 761746041c669fa3673a3e90ec7a247abd0e2782bdddf0fc5d7ab70b33b6f975 SHA512 8812436843721b7134ec796549092854050d1e9017fef048a62e7aa0e866d20e9757b246dbad738cdf8d8583afada3a2db9c6c7dc2546154cafd4dcd0f27f7f2 WHIRLPOOL 767a2a74a9f9b7a0c29407178b96a1455da39239b835f59def2ae77db068655a8953362c6f8d48a8a31fb6fc40dea405c0e6eb276fe60750e9dfbb11954bd972
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.106.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.106.ebuild
new file mode 100644
index 000000000000..6366adcabf62
--- /dev/null
+++ b/app-text/lcdf-typetools/lcdf-typetools-2.106.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Font utilities for eg manipulating OTF"
+SRC_URI="http://www.lcdf.org/type/${P}.tar.gz"
+HOMEPAGE="http://www.lcdf.org/type/#typetools"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="+kpathsea"
+
+RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ use kpathsea && has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ econf $(use_with kpathsea)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS.md README.md ONEWS
+}