summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-03-12 23:27:49 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-12 23:29:05 +0100
commit2cf42072fd6fc4b46bdcac05ffa0e49dd71408d1 (patch)
tree0130114b3229c76e25729dc85b655bc72b11f6cb
parentapp-vim/zoomwin: clean up old. (diff)
downloadgentoo-2cf42072fd6fc4b46bdcac05ffa0e49dd71408d1.tar.gz
gentoo-2cf42072fd6fc4b46bdcac05ffa0e49dd71408d1.tar.bz2
gentoo-2cf42072fd6fc4b46bdcac05ffa0e49dd71408d1.zip
app-vim/lustyexplorer: EAPI 6 bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild b/app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild
new file mode 100644
index 000000000000..18e37c2dd2f7
--- /dev/null
+++ b/app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: dynamic filesystem and buffer explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1890"
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="lusty-explorer.txt"
+
+RDEPEND="|| (
+ app-editors/vim[ruby]
+ app-editors/gvim[ruby]
+)"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc || die
+ sed -e '0,/"$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+ -e "s/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/" \
+ plugin/lusty-explorer.vim > doc/lusty-explorer.txt
+}