summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2018-07-11 16:13:48 +0100
committerJonathan Scruggs <dracwyrm@gentoo.org>2018-08-11 11:09:15 +0100
commit2da39a98096bae76422ceec565aa820d2a0b26a6 (patch)
treec3a2edbd4f793c24da7bdfc97cd8b73c5020f0c9
parentlxqt-base/lxqt-admin: version update to 0.13.0 (diff)
downloadgentoo-2da39a98096bae76422ceec565aa820d2a0b26a6.tar.gz
gentoo-2da39a98096bae76422ceec565aa820d2a0b26a6.tar.bz2
gentoo-2da39a98096bae76422ceec565aa820d2a0b26a6.zip
lxqt-base/lxqt-config: version update to 0.13.0
Added patch from Alec Moskvin <alecm@gmx.com> to remove the Qt5Concurrent dependency.
-rw-r--r--lxqt-base/lxqt-config/Manifest1
-rw-r--r--lxqt-base/lxqt-config/files/lxqt-config-0.13.0-remove-dependency-on-QtConcurrent.patch34
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-0.13.0.ebuild67
-rw-r--r--lxqt-base/lxqt-config/metadata.xml14
4 files changed, 112 insertions, 4 deletions
diff --git a/lxqt-base/lxqt-config/Manifest b/lxqt-base/lxqt-config/Manifest
index b108d3897048..92874a4ea7ea 100644
--- a/lxqt-base/lxqt-config/Manifest
+++ b/lxqt-base/lxqt-config/Manifest
@@ -1 +1,2 @@
DIST lxqt-config-0.11.0.tar.xz 197112 BLAKE2B 2b7da999a61922b4a54e7dd6481c54e4e98262340d596f334058ea8e2d235baff96b39a27ddacadf6678a6f283a7ac63d7160747c31e2bb395036a3657b71030 SHA512 20a573ba6cb83ef19b58a31180924e527496f4eb5d5f9bcf1eb37e3883b8b46ea02f08be9fe42a06f12508ffa2a9af5225d3fe00856ee7807704a99adf654795
+DIST lxqt-config-0.13.0.tar.xz 201112 BLAKE2B 6a79c1f07e1cf055da09bb7dd8f7da2426891770b0e757ba3c4e5ef137f715ba3a579b2c05a4f1938c9d76b6dda0643119888be7dace2083a57a7dfe0df93aa5 SHA512 a5102794c4cf18a18e633cbc7d0b89653abf2612bc61e506ec169f4898903092f5201a09a2610642c641a17b59a992a6d6f59366ec61d54763e8b911d5220ca9
diff --git a/lxqt-base/lxqt-config/files/lxqt-config-0.13.0-remove-dependency-on-QtConcurrent.patch b/lxqt-base/lxqt-config/files/lxqt-config-0.13.0-remove-dependency-on-QtConcurrent.patch
new file mode 100644
index 000000000000..39bf078ae13f
--- /dev/null
+++ b/lxqt-base/lxqt-config/files/lxqt-config-0.13.0-remove-dependency-on-QtConcurrent.patch
@@ -0,0 +1,34 @@
+From e49e5ebabbf8bbe30d4955bc6cb785303f94c6f6 Mon Sep 17 00:00:00 2001
+From: Alec Moskvin <alecm@gmx.com>
+Date: Sun, 15 Jul 2018 11:26:16 -0400
+Subject: [PATCH] Remove dependency on QtConcurrent
+
+---
+ CMakeLists.txt | 1 -
+ lxqt-config-file-associations/CMakeLists.txt | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9c42ddc..5fb2548 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -22,7 +22,6 @@ set(CMAKE_AUTORCC ON)
+ find_package(Qt5Widgets REQUIRED)
+ find_package(Qt5DBus REQUIRED)
+ find_package(Qt5Xml REQUIRED)
+-find_package(Qt5Concurrent REQUIRED)
+ find_package(Qt5X11Extras REQUIRED)
+ find_package(Qt5LinguistTools REQUIRED)
+ find_package(lxqt REQUIRED)
+diff --git a/lxqt-config-file-associations/CMakeLists.txt b/lxqt-config-file-associations/CMakeLists.txt
+index 0506723..2500cf3 100644
+--- a/lxqt-config-file-associations/CMakeLists.txt
++++ b/lxqt-config-file-associations/CMakeLists.txt
+@@ -61,7 +61,6 @@ target_link_libraries(${PROJECT_NAME}
+ Qt5::Xml
+ Qt5::DBus
+ Qt5::Widgets
+- Qt5::Concurrent
+ ${LIBRARIES}
+ )
+
diff --git a/lxqt-base/lxqt-config/lxqt-config-0.13.0.ebuild b/lxqt-base/lxqt-config/lxqt-config-0.13.0.ebuild
new file mode 100644
index 000000000000..d3af64823fcc
--- /dev/null
+++ b/lxqt-base/lxqt-config/lxqt-config-0.13.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils eapi7-ver
+
+DESCRIPTION="LXQt system configuration control center"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+ GPL-3 LGPL-2 LGPL-2+ LGPL-2.1+ WTFPL-2"
+SLOT="0"
+IUSE="+monitor"
+
+RDEPEND="
+ >=dev-libs/libqtxdg-3.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ sys-libs/zlib:=
+ x11-apps/setxkbmap
+ x11-libs/libxcb:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ monitor? ( kde-plasma/libkscreen:5= )
+"
+DEPEND="${DEPEND}
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.5.0
+"
+
+PATCHES=( "${FILESDIR}/${P}-remove-dependency-on-QtConcurrent.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DPULL_TRANSLATIONS=OFF
+ -DWITH_MONITOR="$(usex monitor)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/lxqt-base/lxqt-config/metadata.xml b/lxqt-base/lxqt-config/metadata.xml
index a40a83a9c6a9..d6f2207daed6 100644
--- a/lxqt-base/lxqt-config/metadata.xml
+++ b/lxqt-base/lxqt-config/metadata.xml
@@ -1,8 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>lxqt@gentoo.org</email>
- <name>LXQt</name>
- </maintainer>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/lxqt-config</remote-id>
+ </upstream>
+ <use>
+ <flag name="monitor" restrict="&gt;=lxqt-base/lxqt-config-0.13.0">Build monitor settings tool</flag>
+ </use>
</pkgmetadata>