summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2018-08-02 18:40:53 -0700
committerPatrick McLean <chutzpah@gentoo.org>2018-08-02 18:40:53 -0700
commit2dace3c7bc63b03445bed52ae47bc605a4ef13aa (patch)
tree9800bc95729dab11deda4b5b4532aa49d9d7a6c4
parentdev-python/django-otp: Version bump to 0.4.3 (diff)
downloadgentoo-2dace3c7bc63b03445bed52ae47bc605a4ef13aa.tar.gz
gentoo-2dace3c7bc63b03445bed52ae47bc605a4ef13aa.tar.bz2
gentoo-2dace3c7bc63b03445bed52ae47bc605a4ef13aa.zip
dev-python/django-otp-yubikey: Version bump to 0.4.2
Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--dev-python/django-otp-yubikey/Manifest1
-rw-r--r--dev-python/django-otp-yubikey/django-otp-yubikey-0.4.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/django-otp-yubikey/Manifest b/dev-python/django-otp-yubikey/Manifest
index eddd3b88ba84..104e9b8da7ac 100644
--- a/dev-python/django-otp-yubikey/Manifest
+++ b/dev-python/django-otp-yubikey/Manifest
@@ -1 +1,2 @@
DIST django-otp-yubikey-0.3.3.tar.gz 14233 BLAKE2B a85eba8bf9c590d4747627baaaa6c038afea7d766203974508ee1ccb6bf807642720fae78a64584230f013daefd87475c5c9f94f1584ed4ddbdcfbdb31aee57d SHA512 80c9ffb42a7109a04eca4fabca33294b3a65abeb12f408cb6d7c6c06644896629df43d32833d514e0a60ddd6352af073fb5b2f1174a07b370214a76ccc093c3e
+DIST django-otp-yubikey-0.4.2.tar.gz 12670 BLAKE2B faf060cdc242378ba762ee6af4cfa124da60388ed23fbb33016e47dfe22542075573d9792924f72701aa09d1dde37a79f56674b26d83c2936223602f4ab1eea4 SHA512 bc6fca539e28b52086768c2874d333c7f42b69de4cbd99e57c3cbbb4d0aeae31335a54d6d7f03a9252c0524e75ca20263106d1aabe30a21f5b4046fb2fc2effd
diff --git a/dev-python/django-otp-yubikey/django-otp-yubikey-0.4.2.ebuild b/dev-python/django-otp-yubikey/django-otp-yubikey-0.4.2.ebuild
new file mode 100644
index 000000000000..21e25622065a
--- /dev/null
+++ b/dev-python/django-otp-yubikey/django-otp-yubikey-0.4.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="django-otp plugin that verifies YubiKey OTP tokens"
+HOMEPAGE="https://bitbucket.org/psagers/django-otp"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/django-otp-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/yubiotp-0.2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"