summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-27 08:11:50 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-27 08:11:50 +0200
commit2e0d7c53328c1f14e76e7959918fc7130a3649bf (patch)
tree91b622ecee157c5d2e1c2aee60b47d419fa09b34
parentnet-im/pidgin: no need to restrict OpenSSL from libgadu - dropped in all vers... (diff)
downloadgentoo-2e0d7c53328c1f14e76e7959918fc7130a3649bf.tar.gz
gentoo-2e0d7c53328c1f14e76e7959918fc7130a3649bf.tar.bz2
gentoo-2e0d7c53328c1f14e76e7959918fc7130a3649bf.zip
dev-ruby/dalli: add 2.7.11
Closes: https://bugs.gentoo.org/719344 Closes: https://bugs.gentoo.org/738656 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/dalli/Manifest1
-rw-r--r--dev-ruby/dalli/dalli-2.7.11.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/dalli/Manifest b/dev-ruby/dalli/Manifest
index 24785f4f7d13..d41fd82a4271 100644
--- a/dev-ruby/dalli/Manifest
+++ b/dev-ruby/dalli/Manifest
@@ -1 +1,2 @@
DIST dalli-2.7.10.tar.gz 52106 BLAKE2B 0531247c1d615acd7d1124b8aceb5635088b55e5a85753f10b8fbd786ec3573f13df096e1537d9a31f3801632406f28d918de5971cb28ec31d6eb8387d0c74f1 SHA512 1b6308ef37d729d85741306c10bf87c9b9733f83f0b4bf089f3eced36c48cddd9a77d2fb44a77778844d1cafaa3cec5110a9c90f6a67dee08a96e163e6ccaf65
+DIST dalli-2.7.11.tar.gz 52341 BLAKE2B 5b3a2bc57f4b0e3a9ac0d24ffa3bba89ea38665ac08ef3d7760fa6ce74db21d323a18e74a4f3009165364332731d7c6890df36c68409afbe21d3ac096275f028 SHA512 8f299a19d95293370564b6337bbdfeb32d928e0a95bf5f5df962ea20b039f4765da1797513ca96cabf93309484575481a02fb1e0c6d227f74c81fc72f95be22a
diff --git a/dev-ruby/dalli/dalli-2.7.11.ebuild b/dev-ruby/dalli/dalli-2.7.11.ebuild
new file mode 100644
index 000000000000..a8a2a8ccf9e1
--- /dev/null
+++ b/dev-ruby/dalli/dalli-2.7.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.md Performance.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
+HOMEPAGE="https://github.com/petergoldstein/dalli"
+SRC_URI="https://github.com/petergoldstein/dalli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+IUSE=""
+
+DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.5.4 )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:5
+ >=dev-ruby/mocha-0.13
+ dev-ruby/rack
+ >=dev-ruby/activesupport-5.2
+ dev-ruby/connection_pool )"
+
+all_ruby_prepare() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die
+
+ sed -i -e '3igem "minitest", "~> 5.0"; gem "activesupport", ">=5.2.0"' \
+ -e '/bundler/ s:^:#:' test/helper.rb || die
+
+ # Drop rails dependency which is only used to display the version
+ # number, so we only need to depend on activesupport and avoid
+ # complicated circular dependencies.
+ sed -i -e '/rails/I s:^:#:' \
+ -e '14irequire "active_support"' test/helper.rb || die
+
+ # Fix test compatability with memcached 1.5.4 and higher
+ # https://github.com/petergoldstein/dalli/pull/672
+ #sed -i -e '/memcached_low_mem_persistent/,/^end/ s/-M/-M -I 512k/' test/memcached_mock.rb || die
+}