summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-31 07:51:05 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-31 08:21:05 +0200
commit2f4923205603876306017751e12792c8e22c4165 (patch)
treef62ab8ede5d324dc5b748256db6442acc06b3b6a
parentdev-python/pymongo: Bump to 3.11.0 (diff)
downloadgentoo-2f4923205603876306017751e12792c8e22c4165.tar.gz
gentoo-2f4923205603876306017751e12792c8e22c4165.tar.bz2
gentoo-2f4923205603876306017751e12792c8e22c4165.zip
dev-python/wtforms: Bump to 2.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wtforms/Manifest1
-rw-r--r--dev-python/wtforms/wtforms-2.3.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
index 1946487d7fa2..84ad9c946c5e 100644
--- a/dev-python/wtforms/Manifest
+++ b/dev-python/wtforms/Manifest
@@ -1,2 +1,3 @@
DIST WTForms-2.2.1.tar.gz 156904 BLAKE2B bec7c526f72b264888f7be45ba15d2bc4d194b09adc8ca5806cfc04cd1671663c851b7f1c99c602bb3e13d14a38733be61613058e46481bcea59901ac1f5b6b2 SHA512 06478790a8a4bf728e5436edaa63c7c0e596f71d63b273e1f296f9255d9fa3e31a7bfa95971c214a8cea684034ac3c77b05371f4b4e14da9d9ef2c5afadabde0
DIST WTForms-2.3.1.tar.gz 162773 BLAKE2B b51b5cb26c550a2502c8c70c1de91c7e6e320f60e2df3ab2b9a5cd755dbbb753d8d2fa05837657aa639929b380e8c65fd25182192538ccef837cae0869b19c80 SHA512 40b810d2d0ce6d2e7880615fb5c3b3e55cfade8e352be5d626d0de16f00a9ef4626ffa106b67d0cbef15e42513073db52ba1ceb04cb18146bba0ba9c26236fdd
+DIST WTForms-2.3.3.tar.gz 162945 BLAKE2B 5f9f2c920ffc784c34d69f42cd259c1cb6007edbc99028bede98b7c3e24b8ba616b89eceac241cc9b20b241e758ee0c88a9c6736597ddc83c90542135a004fec SHA512 934cf1483beec37d698d13a81e44a733d082baad1f418d3087306fd908df809d37fffe000ed1ecabf65d2c31b57034bf6f25c3b77cfc5598ae1f65bf4a115fe5
diff --git a/dev-python/wtforms/wtforms-2.3.3.ebuild b/dev-python/wtforms/wtforms-2.3.3.ebuild
new file mode 100644
index 000000000000..6651bb04febe
--- /dev/null
+++ b/dev-python/wtforms/wtforms-2.3.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+inherit distutils-r1
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="https://wtforms.readthedocs.io/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/markupsafe[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-email-validator[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Extension-tests are written for an older version of Django
+ # Disable pep8 even when it is installed
+ sed \
+ -e "s|'ext_django.tests', ||" \
+ -e "/import pep8/d" \
+ -e "s|has_pep8 = True|has_pep8 = False|" \
+ -i tests/runtests.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" tests/runtests.py -v || die
+}