summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-05-09 03:40:40 -0500
committerTim Harder <radhermit@gentoo.org>2019-05-09 03:40:40 -0500
commit2f7d0996797f9cc32a94277da743e3efda308b59 (patch)
tree6468ed027e988c3ad501b9e3e3e174f81ccebb90
parentprofiles/package.mask: drop languagetool package masks (diff)
downloadgentoo-2f7d0996797f9cc32a94277da743e3efda308b59.tar.gz
gentoo-2f7d0996797f9cc32a94277da743e3efda308b59.tar.bz2
gentoo-2f7d0996797f9cc32a94277da743e3efda308b59.zip
media-sound/abcmidi: version bump to 2019.05.08
Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--media-sound/abcmidi/Manifest1
-rw-r--r--media-sound/abcmidi/abcmidi-2019.05.08.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/abcmidi/Manifest b/media-sound/abcmidi/Manifest
index 4389154801a7..8643ea110109 100644
--- a/media-sound/abcmidi/Manifest
+++ b/media-sound/abcmidi/Manifest
@@ -1,2 +1,3 @@
DIST abcMIDI-2018.06.23.zip 564262 BLAKE2B 0c99e5bb0787f4a41381ec77b1a64da273955997f0788eded8149297e332d05224e02eca2eb5a1b846b3314d7a62dad7eb3997ac2ed4c4aa4b13d0f099f08afb SHA512 d1f95fae383432d4ecb09fd7136212d42bb0a7b08fc7372b2511ecfbeff9fa0b51cd242f46f20827cf4122bc04e35c8a8442af4666b0e7093e6ad91302bb40ba
DIST abcMIDI-2018.12.21.zip 558423 BLAKE2B e40e8d01744d623042445642b21aa6654d5ba087bfb426b62e9ff44ea39d20f6b3b8f1d94d406362e63ab173a3ff721c737fd945b2195e42468d458aa3d8a176 SHA512 5f338852f3c65dcdfac760c1ab50d05654930f4b02701ffe44b0f8f830e39108ede63b7b47eb751790c6c2730af74dbd1e9b3ec361c5242ecef81376259399c7
+DIST abcMIDI-2019.05.08.zip 562151 BLAKE2B 7b7413b329a69c9f8e7cf8eec9ddb2caceb055d2256d01a2e6045008b861b8aac194bb0b2507fb96a21ddcfe228a789be63c1ad322945a7b824ff39908cefcf4 SHA512 3891e10503f319b406b175d18077c353767b1025bae73fed184988427602412ffd5bb8e1ec0513b9ebff4d0debd81535558a8157b150a4e32abad099279d4312
diff --git a/media-sound/abcmidi/abcmidi-2019.05.08.ebuild b/media-sound/abcmidi/abcmidi-2019.05.08.ebuild
new file mode 100644
index 000000000000..ce075821d84d
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2019.05.08.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="abcMIDI-${PV}"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="https://ifdo.ca/~seymour/runabc/top.html"
+SRC_URI="https://ifdo.ca/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ local PATCHES=( "${FILESDIR}"/${PN}-2016.05.05-docs.patch )
+ default
+
+ rm configure Makefile || die
+ sed -i "s:-O2::" configure.ac || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}