summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-10-22 22:28:24 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2015-10-22 22:32:03 +0100
commit300667cace72259e9298123e6df82b33fee3eb3f (patch)
tree979031d5ed1e2fe07cf68bb8517c25f072692d9e
parentdev-haskell/djinn-ghc: new package (diff)
downloadgentoo-300667cace72259e9298123e6df82b33fee3eb3f.tar.gz
gentoo-300667cace72259e9298123e6df82b33fee3eb3f.tar.bz2
gentoo-300667cace72259e9298123e6df82b33fee3eb3f.zip
dev-haskell/pipes: new package
"Compositional pipelines", a depend of app-emacs/ghc-mod Bug: https://bugs.gentoo.org/show_bug.cgi?id=476352 Package-Manager: portage-2.2.23
-rw-r--r--dev-haskell/pipes/Manifest1
-rw-r--r--dev-haskell/pipes/metadata.xml32
-rw-r--r--dev-haskell/pipes/pipes-4.1.6.ebuild31
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-haskell/pipes/Manifest b/dev-haskell/pipes/Manifest
new file mode 100644
index 000000000000..d556bda6ea51
--- /dev/null
+++ b/dev-haskell/pipes/Manifest
@@ -0,0 +1 @@
+DIST pipes-4.1.6.tar.gz 38387 SHA256 2d6a5060380497a16287d156c69cbd55d2d3efc6d57d5079f794f90c944e7435 SHA512 a5467658ad9e60b8d2ba39fe4c8fca228388484e9a534e284b51069abc3a7f61382d0cdd6277fa99d5295af06d05496cd2cf4acbdec7cc1556de870d6b0abedd WHIRLPOOL afec914749e101feda0c5d32f405fb3a6e69917048524dfd6e4e22a22e5bd864a016995881774032d2d1d05b1c283da78aa7362be7d1f5d0be53fd45c57a4dc4
diff --git a/dev-haskell/pipes/metadata.xml b/dev-haskell/pipes/metadata.xml
new file mode 100644
index 000000000000..739bd909e065
--- /dev/null
+++ b/dev-haskell/pipes/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ \&quot;Coroutines done right\&quot;. This library generalizes iteratees and coroutines
+ simply and elegantly.
+
+ Advantages over traditional iteratee\/coroutine implementations:
+
+ * /Concise API/: Use three simple commands: (&#39;&gt;-&gt;&#39;), &#39;request&#39;, and &#39;respond&#39;
+
+ * /Bidirectionality/: Implement duplex channels
+
+ * /Blazing fast/: Implementation tuned for speed
+
+ * /Elegant semantics/: Use practical category theory
+
+ * /Extension Framework/: Mix and match extensions and create your own
+
+ * /ListT/: Correct implementation of ListT that interconverts with pipes
+
+ * /Lightweight Dependency/: @pipes@ depends only on @transformers@ and
+ @mmorph@ and compiles rapidly
+
+ * /Extensive Documentation/: Second to none!
+
+ Import &quot;Control.Proxy&quot; to use the library.
+
+ Read &quot;Control.Proxy.Tutorial&quot; for an extensive tutorial.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/pipes/pipes-4.1.6.ebuild b/dev-haskell/pipes/pipes-4.1.6.ebuild
new file mode 100644
index 000000000000..4543dd4c679f
--- /dev/null
+++ b/dev-haskell/pipes/pipes-4.1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compositional pipelines"
+HOMEPAGE="http://hackage.haskell.org/package/pipes"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mmorph-1.0.0:=[profile?] <dev-haskell/mmorph-1.1:=[profile?]
+ >=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/transformers-0.2.0.0:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-3
+ >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-1
+ >=dev-haskell/test-framework-quickcheck2-0.2.0 <dev-haskell/test-framework-quickcheck2-0.4 )
+"