summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-01-20 03:08:20 +1300
committerKent Fredric <kentnl@gentoo.org>2017-01-20 03:16:10 +1300
commit30ab0ec9760f61c6a38c7dc42b0cf648ecaac981 (patch)
treee19bef4941ac57eb0f3afbc1caf2f0f231875f96
parentdev-perl/Mojolicious: Bump to version 7.200.0 (diff)
downloadgentoo-30ab0ec9760f61c6a38c7dc42b0cf648ecaac981.tar.gz
gentoo-30ab0ec9760f61c6a38c7dc42b0cf648ecaac981.tar.bz2
gentoo-30ab0ec9760f61c6a38c7dc42b0cf648ecaac981.zip
dev-perl/libwww-perl: Bump to version 6.160.0
- EAPI6 - Tests enabled Upstream: - LWP::Protocol::GHTTP moved to its own dist (Not yet added to gentoo on the basis that anything using this would already need a dep on HTTP::GHTTP as well, which is not in tree either) - Test suite updated - Allow default header to carry over when using UA->post Keywording: - Dropped all but x86 and amd64 due to new dependencies Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-perl/libwww-perl/Manifest1
-rw-r--r--dev-perl/libwww-perl/libwww-perl-6.160.0.ebuild68
-rw-r--r--dev-perl/libwww-perl/metadata.xml1
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-perl/libwww-perl/Manifest b/dev-perl/libwww-perl/Manifest
index 16f16d09937c..25f00d556e44 100644
--- a/dev-perl/libwww-perl/Manifest
+++ b/dev-perl/libwww-perl/Manifest
@@ -1 +1,2 @@
DIST libwww-perl-6.15.tar.gz 141936 SHA256 6f349d45c21b1ec0501c4437dfcb70570940e6c3d5bff783bd91d4cddead8322 SHA512 b031f1b6766fe5433940abbda438013211e0f82713bfbe8f3512fd3dd64d2c7b1236d19bb9414094726a37ee91908ebca5269855a639d0fd921423163b227aed WHIRLPOOL 808921729702a443950f697ae7d691bafe07a2641aafb6ffc31342301f5881c375dcb35b0f8f11d57d84a13c0d0b79bbfa23d52395e6e689e0381c379d48af03
+DIST libwww-perl-6.16.tar.gz 143751 SHA256 daffd268000f92d241f8ae5508ae5616dbd02f15a587b4fbcd14998ccc15ce22 SHA512 7652d3d79d2638c523140fe8bd0df5bf691d070ad9b972c62f1f3771478b98f72909299b58cf20d280967b99cb2daa7e382916d1f8a3775da0cf9c7457d9d3ca WHIRLPOOL 3ea817eddd83a289eff37ac14a8778252fa125572c16295588019ba53f8babf1f87bddb7fa283586184a610d185bdff430dd5e0b65392de63553a9f10cdc3e14
diff --git a/dev-perl/libwww-perl/libwww-perl-6.160.0.ebuild b/dev-perl/libwww-perl/libwww-perl-6.160.0.ebuild
new file mode 100644
index 000000000000..e834c26691df
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-6.160.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=6.16
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl test"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ >=virtual/perl-Encode-2.120.0
+ dev-perl/Encode-Locale
+ >=dev-perl/File-Listing-6.0.0
+ >=dev-perl/HTML-Parser-3.340.0
+ >=dev-perl/HTTP-Cookies-6.0.0
+ >=dev-perl/HTTP-Daemon-6.0.0
+ >=dev-perl/HTTP-Date-6.0.0
+ >=dev-perl/HTTP-Negotiate-6.0.0
+ >=dev-perl/HTTP-Message-6.0.0
+ virtual/perl-IO
+ >=dev-perl/LWP-MediaTypes-6.0.0
+ >=virtual/perl-MIME-Base64-2.120.0
+ >=dev-perl/Net-HTTP-6.70.0
+ >=dev-perl/URI-1.100.0
+ >=dev-perl/WWW-RobotRules-6.0.0
+ >=virtual/perl-libnet-1.220.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Getopt-Long
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Test-RequiresInternet
+ virtual/perl-Test-Simple
+ )
+"
+PDEPEND="
+ ssl? (
+ >=dev-perl/LWP-Protocol-https-6.20.0
+ )
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Perform a check to see if the live filesystem is case-INsensitive
+ # or not. If it is, the symlinks GET, POST and in particular HEAD
+ # will collide with e.g. head from coreutils. While under Linux
+ # having a case-INsensitive filesystem is really unusual, most Mac
+ # OS X users are on it, and also Interix users deal with
+ # case-INsensitivity since Windows is underneath.
+
+ # bash should always be there, if we can find it in capitals, we're
+ # on a case-INsensitive filesystem.
+ if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+ fi
+}
diff --git a/dev-perl/libwww-perl/metadata.xml b/dev-perl/libwww-perl/metadata.xml
index e6779d048b3e..a24947559fa3 100644
--- a/dev-perl/libwww-perl/metadata.xml
+++ b/dev-perl/libwww-perl/metadata.xml
@@ -16,7 +16,6 @@
<remote-id type="cpan-module">LWP::DebugFile</remote-id>
<remote-id type="cpan-module">LWP::MemberMixin</remote-id>
<remote-id type="cpan-module">LWP::Protocol</remote-id>
- <remote-id type="cpan-module">LWP::Protocol::GHTTP</remote-id>
<remote-id type="cpan-module">LWP::Protocol::MyFTP</remote-id>
<remote-id type="cpan-module">LWP::Protocol::cpan</remote-id>
<remote-id type="cpan-module">LWP::Protocol::data</remote-id>