summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-05-06 20:32:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 00:56:12 +0200
commit3111c1f0ff244182fc5439fabba161b2b58c33b0 (patch)
treefd5f6e38c4a298d7e559e28010108fea8e452dba
parentmedia-sound/yarock: Drop 1.3.1 (diff)
downloadgentoo-3111c1f0ff244182fc5439fabba161b2b58c33b0.tar.gz
gentoo-3111c1f0ff244182fc5439fabba161b2b58c33b0.tar.bz2
gentoo-3111c1f0ff244182fc5439fabba161b2b58c33b0.zip
dev-libs/libidmef: EAPI=7 update
Closes: https://bugs.gentoo.org/685218 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11921 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/libidmef/libidmef-1.0.3-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/libidmef/libidmef-1.0.3-r1.ebuild b/dev-libs/libidmef/libidmef-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..e7cba52e4f70
--- /dev/null
+++ b/dev-libs/libidmef/libidmef-1.0.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implementation of the IDMEF XML draft"
+HOMEPAGE="https://sourceforge.net/projects/libidmef/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND=">=dev-libs/libxml2-2.5.10"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}