summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-22 14:09:59 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-05 22:00:48 +0100
commit326360af22a1f24fca60d975e5e5aa4ab1a57d6a (patch)
treea871d8f5c25a5edec3165b2e8f91617ac9aae19c
parentprofiles: Add default PYTHON_SINGLE_TARGET for dev-libs/lib{ixion,orcus} (diff)
downloadgentoo-326360af22a1f24fca60d975e5e5aa4ab1a57d6a.tar.gz
gentoo-326360af22a1f24fca60d975e5e5aa4ab1a57d6a.tar.bz2
gentoo-326360af22a1f24fca60d975e5e5aa4ab1a57d6a.zip
app-office/unoconv: Port to python-single-r1, bump to EAPI 6
0.7 was fixed already, do the same for 99999999. Gentoo-bug: 597466 Package-Manager: portage-2.3.0
-rw-r--r--app-office/unoconv/files/timeout.patch4
-rw-r--r--app-office/unoconv/unoconv-99999999.ebuild42
2 files changed, 44 insertions, 2 deletions
diff --git a/app-office/unoconv/files/timeout.patch b/app-office/unoconv/files/timeout.patch
index f41b101faf78..784920536e94 100644
--- a/app-office/unoconv/files/timeout.patch
+++ b/app-office/unoconv/files/timeout.patch
@@ -1,5 +1,5 @@
---- unoconv.old 2011-08-01 14:20:45.000000000 +0200
-+++ unoconv 2011-08-01 14:21:01.000000000 +0200
+--- a/unoconv 2011-08-01 14:20:45.000000000 +0200
++++ b/unoconv 2011-08-01 14:21:01.000000000 +0200
@@ -534,7 +534,7 @@
unocontext = resolver.resolve("uno:%s" % op.connection)
break
diff --git a/app-office/unoconv/unoconv-99999999.ebuild b/app-office/unoconv/unoconv-99999999.ebuild
new file mode 100644
index 000000000000..f498ce777cd5
--- /dev/null
+++ b/app-office/unoconv/unoconv-99999999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+EGIT_REPO_URI="https://github.com/dagwieers/unoconv.git"
+[[ ${PV} == 9999* ]] && SCM_ECLASS="git-r3"
+inherit python-single-r1 ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
+[[ ${PV} == 9999* ]] || SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ ${PV} == 9999* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+DOCS=( ChangeLog CHANGELOG.md README.adoc )
+
+PATCHES=( "${FILESDIR}/timeout.patch" )
+
+src_compile() { :; }
+
+src_install() {
+ emake doc-install install install-links DESTDIR="${D}" || die
+ einstalldocs
+ python_fix_shebang .
+}