summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-01-23 21:45:17 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-01-23 21:45:17 +0000
commit3320765934d8cd668cdd3a758cd816c88832b7db (patch)
tree2c8c9ceb4abbdcefa9567ddc0e4e6f6ab3bd42a3
parent2019-01-23 21:24:32 UTC (diff)
parentdev-libs/spdlog: verbump to 1.3.1 (diff)
downloadgentoo-3320765934d8cd668cdd3a758cd816c88832b7db.tar.gz
gentoo-3320765934d8cd668cdd3a758cd816c88832b7db.tar.bz2
gentoo-3320765934d8cd668cdd3a758cd816c88832b7db.zip
Merge updates from master
-rw-r--r--dev-libs/spdlog/Manifest1
-rw-r--r--dev-libs/spdlog/spdlog-1.3.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/spdlog/Manifest b/dev-libs/spdlog/Manifest
index 253b07289660..9beed729a3b6 100644
--- a/dev-libs/spdlog/Manifest
+++ b/dev-libs/spdlog/Manifest
@@ -1,2 +1,3 @@
DIST spdlog-1.2.1.tar.gz 188284 BLAKE2B c3491a9c44d8a94c51d50c9ef36a2105f77e8fb61bb7b2b81a341609f433abbe3a74e7b4a467dd715a5d906f976740716488d07b4510f366556ab59d160ceefe SHA512 418f91efc207fa227558212d82c41639c0bb59e84ea47447e0b6276c4842e97f1f8aaf5802c071ef15d80ec525e317e70b6a39661a6c96ab39d33d9bd1570da1
DIST spdlog-1.3.0.tar.gz 202637 BLAKE2B 97027a3672b826e294dbdc202afa913a42ddae5a02a569ac28c41d79b96128de045ac5df30a76d888d6b3bea5093fb75b006365d7b1b296842750a39f43835d6 SHA512 019a52d4b6c66287ee2a6e8177457ecbbb78e1cb894f4a0a90b83a84d66cd37b397cdf77892d9116e4c34113bd3277d606d578bc96ec6521ae7745f08b1aa54f
+DIST spdlog-1.3.1.tar.gz 202634 BLAKE2B 2465a8d1a38af1527ae66d92f5dd91ad504d01e44ac47702e315f7448e19f01743627357132f0561e48807315df9b102f337f95cab5a7aae3ec0ae7ceff940b9 SHA512 a851a44b6384f493dd312ae0a611d068af46bbfe8daf1c2f61f13d8836a3801f41b339074fbe8da8e428131c82fa5c4a9e3320a55cbdd4b7aff8bb349dfff7dd
diff --git a/dev-libs/spdlog/spdlog-1.3.1.ebuild b/dev-libs/spdlog/spdlog-1.3.1.ebuild
new file mode 100644
index 000000000000..497e7da9b419
--- /dev/null
+++ b/dev-libs/spdlog/spdlog-1.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Very fast, header only, C++ logging library"
+HOMEPAGE="https://github.com/gabime/spdlog"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gabime/spdlog"
+else
+ SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="test"
+
+DEPEND="
+ >=dev-libs/libfmt-5.0.0
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.0-unbundle-fmt.patch" )
+
+src_configure() {
+ rm -r include/spdlog/fmt/bundled || die
+
+ local mycmakeargs=(
+ -DSPDLOG_BUILD_EXAMPLES=no
+ -DSPDLOG_BUILD_BENCH=no
+ -DSPDLOG_BUILD_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}