summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-04 23:49:11 +0100
committerSam James <sam@gentoo.org>2021-05-04 23:49:11 +0100
commit332813b29e4350f990a51934bc7a975794ef4fda (patch)
tree755681c01f8fad2c43e8769d3d8cbd5f42d5e8ee
parentmedia-video/vlc: allow building against newer net-libs/srt (diff)
downloadgentoo-332813b29e4350f990a51934bc7a975794ef4fda.tar.gz
gentoo-332813b29e4350f990a51934bc7a975794ef4fda.tar.bz2
gentoo-332813b29e4350f990a51934bc7a975794ef4fda.zip
net-libs/srt: fix build with GCC 11
Closes: https://bugs.gentoo.org/787023 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-libs/srt/files/srt-1.4.2-cxx-include-gcc11.patch19
-rw-r--r--net-libs/srt/srt-1.4.2.ebuild1
2 files changed, 20 insertions, 0 deletions
diff --git a/net-libs/srt/files/srt-1.4.2-cxx-include-gcc11.patch b/net-libs/srt/files/srt-1.4.2-cxx-include-gcc11.patch
new file mode 100644
index 000000000000..16c57af80929
--- /dev/null
+++ b/net-libs/srt/files/srt-1.4.2-cxx-include-gcc11.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/787023
+https://github.com/Haivision/srt/commit/f1b35cbf5b9b42b031e9b119e4c802b5f744468c
+
+From f1b35cbf5b9b42b031e9b119e4c802b5f744468c Mon Sep 17 00:00:00 2001
+From: Christophe Giboudeaux <krop@users.noreply.github.com>
+Date: Wed, 10 Feb 2021 12:42:45 +0000
+Subject: [PATCH] [core] Fix build with GCC 11. (#1806)
+
+The 'limits' header must be included explicitly.
+--- a/srtcore/sync.h
++++ b/srtcore/sync.h
+@@ -15,6 +15,7 @@
+ //#define ENABLE_CXX17
+
+ #include <cstdlib>
++#include <limits>
+ #ifdef ENABLE_STDCXX_SYNC
+ #include <chrono>
+ #include <thread>
diff --git a/net-libs/srt/srt-1.4.2.ebuild b/net-libs/srt/srt-1.4.2.ebuild
index cbade3405e2a..de77f27cd91a 100644
--- a/net-libs/srt/srt-1.4.2.ebuild
+++ b/net-libs/srt/srt-1.4.2.ebuild
@@ -34,6 +34,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-always-GNUInstallDirs.patch"
+ "${FILESDIR}/${P}-cxx-include-gcc11.patch"
)
src_prepare() {