summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-01-01 23:42:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-01-01 23:44:44 +0100
commit335949ee475f372a92f8a3a2ff28e2f5c0c3b931 (patch)
treed43bbd6956d649f99a0c53931332350a667f81b5
parentnet-misc/tor: amd64 stable wrt bug #603174 (diff)
downloadgentoo-335949ee475f372a92f8a3a2ff28e2f5c0c3b931.tar.gz
gentoo-335949ee475f372a92f8a3a2ff28e2f5c0c3b931.tar.bz2
gentoo-335949ee475f372a92f8a3a2ff28e2f5c0c3b931.zip
kde-frameworks/sonnet: Fix configure w/ future hunspell
Package-Manager: portage-2.3.0
-rw-r--r--kde-frameworks/sonnet/sonnet-5.26.0.ebuild10
-rw-r--r--kde-frameworks/sonnet/sonnet-5.29.0.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/kde-frameworks/sonnet/sonnet-5.26.0.ebuild b/kde-frameworks/sonnet/sonnet-5.26.0.ebuild
index 18c39b4d609e..27fe13acb1f4 100644
--- a/kde-frameworks/sonnet/sonnet-5.26.0.ebuild
+++ b/kde-frameworks/sonnet/sonnet-5.26.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -21,6 +21,14 @@ DEPEND="${RDEPEND}
nls? ( $(add_qt_dep linguist-tools) )
"
+src_prepare() {
+ kde5_src_prepare
+
+ # ensure at least one version-free atom so that hunspell is found
+ sed -e "/FIND_LIBRARY(HUNSPELL_LIBRARIES/ s/\bhunspell\b-[0-9.]*/hunspell/" \
+ -i cmake/FindHUNSPELL.cmake || die
+}
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package aspell ASPELL)
diff --git a/kde-frameworks/sonnet/sonnet-5.29.0.ebuild b/kde-frameworks/sonnet/sonnet-5.29.0.ebuild
index 46783f1573e3..5b0ae24f3837 100644
--- a/kde-frameworks/sonnet/sonnet-5.29.0.ebuild
+++ b/kde-frameworks/sonnet/sonnet-5.29.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -21,6 +21,14 @@ DEPEND="${RDEPEND}
nls? ( $(add_qt_dep linguist-tools) )
"
+src_prepare() {
+ kde5_src_prepare
+
+ # ensure at least one version-free atom so that hunspell is found
+ sed -e "/FIND_LIBRARY(HUNSPELL_LIBRARIES/ s/\bhunspell\b-[0-9.]*/hunspell/" \
+ -i cmake/FindHUNSPELL.cmake || die
+}
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package aspell ASPELL)