summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-27 11:41:00 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-27 12:20:27 +0100
commit3418e2f50b631976d5943802e112e9a5be8c4f8c (patch)
tree4565e09a62b7550448d3bbd51f534a8778bd38f6
parentwww-client/vivaldi: Stable for AMD64 x86 too. (diff)
downloadgentoo-3418e2f50b631976d5943802e112e9a5be8c4f8c.tar.gz
gentoo-3418e2f50b631976d5943802e112e9a5be8c4f8c.tar.bz2
gentoo-3418e2f50b631976d5943802e112e9a5be8c4f8c.zip
www-misc/wsmake: Port to EAPI 6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--www-misc/wsmake/Manifest2
-rw-r--r--www-misc/wsmake/files/wsmake-0.6.4-bv.diff4
-rw-r--r--www-misc/wsmake/files/wsmake-0.6.4-fix-const-va_list.patch29
-rw-r--r--www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch12
-rw-r--r--www-misc/wsmake/wsmake-0.6.4.ebuild42
5 files changed, 61 insertions, 28 deletions
diff --git a/www-misc/wsmake/Manifest b/www-misc/wsmake/Manifest
index 9910f5607ec6..8b30b6ff26f3 100644
--- a/www-misc/wsmake/Manifest
+++ b/www-misc/wsmake/Manifest
@@ -1 +1 @@
-DIST wsmake-0.6.4.tar.bz2 351688 SHA256 884ca4e635d454776888526cf94f6af6639f76b317aa10f9f6d651d9208188d6 SHA512 0f5d125053222c624f9c19f4147f0d97311acb11050e09112ae7b13175ea64d0ba75942c5772e2ffe12d2913cea370ed663d7cb649eef67e0f8379775a3459c4 WHIRLPOOL a72eae2811936ed27cbdc63fec9bbf25999dbfdc95d0cdf81e357fc5bb130b10571332520e6aae2537707c0a40d08aff6995276487eb4d0b66e70014a44db5ab
+DIST wsmake-0.6.4.tar.bz2 351688 BLAKE2B 4e810b1b5f697bc8a7bbb27a4023ff50f90fbcab5f9bf7890277ebb95d5fbf90cfaad51f181c4a76bd532f802fd4eaf07dbab6757a15ee242f80dbef19ce0b08 SHA512 0f5d125053222c624f9c19f4147f0d97311acb11050e09112ae7b13175ea64d0ba75942c5772e2ffe12d2913cea370ed663d7cb649eef67e0f8379775a3459c4
diff --git a/www-misc/wsmake/files/wsmake-0.6.4-bv.diff b/www-misc/wsmake/files/wsmake-0.6.4-bv.diff
index d10aa5769c2d..15cdf05f5d25 100644
--- a/www-misc/wsmake/files/wsmake-0.6.4-bv.diff
+++ b/www-misc/wsmake/files/wsmake-0.6.4-bv.diff
@@ -1,5 +1,5 @@
---- libwsmake/wsUtil.cpp.orig Sat Sep 1 22:09:13 2001
-+++ libwsmake/wsUtil.cpp Tue Sep 3 20:19:04 2002
+--- a/libwsmake/wsUtil.cpp
++++ b/libwsmake/wsUtil.cpp
@@ -714,7 +714,8 @@
if(__wsmake_quiet) return;
diff --git a/www-misc/wsmake/files/wsmake-0.6.4-fix-const-va_list.patch b/www-misc/wsmake/files/wsmake-0.6.4-fix-const-va_list.patch
new file mode 100644
index 000000000000..420bbb61b030
--- /dev/null
+++ b/www-misc/wsmake/files/wsmake-0.6.4-fix-const-va_list.patch
@@ -0,0 +1,29 @@
+--- a/libwsmake/wsUtil.cpp
++++ b/libwsmake/wsUtil.cpp
+@@ -710,13 +710,13 @@
+ }
+ }
+
+-void std::__wsmake_print_it(FILE *out, const char *output, const va_list *ap)
++void std::__wsmake_print_it(FILE *out, const char *output, va_list *ap)
+ {
+ if(__wsmake_quiet) return;
+
+ vfprintf(out,output,*ap);
+ //BV: this does not compile: va_end((void*&)*ap);
+- va_end((char*&)*ap);
++ va_end(*ap);
+ }
+
+ #ifdef DEBUG
+--- a/libwsmake/wsUtil.h
++++ b/libwsmake/wsUtil.h
+@@ -77,7 +77,7 @@
+ void __wsmake_print_error(const char *, ...);
+ void __wsmake_print(const char *, ...);
+ void __wsmake_print(int, const char *, ...);
+- void __wsmake_print_it(FILE *, const char *, const va_list *);
++ void __wsmake_print_it(FILE *, const char *, va_list *);
+ }
+
+ #endif /* __WSUTIL_H__ */
diff --git a/www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch b/www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch
index 0ecfe62003f5..9028c0695546 100644
--- a/www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch
+++ b/www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch
@@ -1,8 +1,8 @@
https://bugs.gentoo.org/show_bug.cgi?id=251745
https://sourceforge.net/tracker/index.php?func=detail&aid=2520894&group_id=5982&atid=105982
---- libwsmake/wsSubTag.cpp
-+++ libwsmake/wsSubTag.cpp.new
+--- a/libwsmake/wsSubTag.cpp
++++ b/libwsmake/wsSubTag.cpp
@@ -22,6 +22,7 @@
***********************************************************************/
#include <cstdio>
@@ -11,8 +11,8 @@ https://sourceforge.net/tracker/index.php?func=detail&aid=2520894&group_id=5982&
#include <unistd.h>
#ifdef HAVE_SYS_WAIT_H
---- libwsmake/wsWebPage.cpp
-+++ libwsmake/wsWebPage.cpp.new
+--- a/libwsmake/wsWebPage.cpp
++++ b/libwsmake/wsWebPage.cpp
@@ -23,6 +23,7 @@
#include <cassert>
#include <cerrno>
@@ -21,8 +21,8 @@ https://sourceforge.net/tracker/index.php?func=detail&aid=2520894&group_id=5982&
#include "wsmake.h"
---- libwsmake/wsUtil.cpp
-+++ libwsmake/wsUtil.cpp.new
+--- a/libwsmake/wsUtil.cpp
++++ b/libwsmake/wsUtil.cpp
@@ -28,6 +28,7 @@
#include <cassert>
#include <cerrno>
diff --git a/www-misc/wsmake/wsmake-0.6.4.ebuild b/www-misc/wsmake/wsmake-0.6.4.ebuild
index 7299d6dc862b..83c599488943 100644
--- a/www-misc/wsmake/wsmake-0.6.4.ebuild
+++ b/www-misc/wsmake/wsmake-0.6.4.ebuild
@@ -1,33 +1,37 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils
+EAPI=6
DESCRIPTION="Website Pre-processor"
HOMEPAGE="http://www.wsmake.org/"
-SRC_URI="http://ftp.wsmake.org/pub/wsmake6/stable/wsmake-0.6.4.tar.bz2"
+SRC_URI="http://ftp.wsmake.org/pub/wsmake6/stable/${P}.tar.bz2"
-KEYWORDS="x86"
LICENSE="GPL-2 Artistic"
SLOT="0"
-IUSE=""
+KEYWORDS="x86"
+IUSE="examples"
-src_unpack () {
- unpack ${A} && cd "${S}"
- epatch "${FILESDIR}"/${P}-bv.diff
- epatch "${FILESDIR}"/${P}-gcc43.patch # 251745
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-bv.diff
+ "${FILESDIR}"/${P}-gcc43.patch # 251745
+ "${FILESDIR}"/${P}-fix-const-va_list.patch
+)
-src_compile () {
- econf || die "econf failed"
- emake || die "emake failed"
- cd doc
+src_unpack() {
+ default
+
+ cd "${S}"/doc || die
tar -cf examples.tar examples || die
}
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS COPYING ChangeLog* DEVELOPERS LICENSE NEWS README TODO
- cd doc
- dodoc manual.txt examples.tar
+src_install() {
+ default
+ dodoc doc/manual.txt
+
+ if use examples; then
+ rm -r doc/examples/CVS || die
+ dodoc -r doc/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
}