summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-27 21:12:01 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-27 21:12:23 +0100
commit3478887cc8b1243d8cfd8fc4a247403476e5e69a (patch)
treefd6601a2f31d1d7cd91f523dee08fea446aab7f7
parentdev-vcs/git-tools: New package. (diff)
downloadgentoo-3478887cc8b1243d8cfd8fc4a247403476e5e69a.tar.gz
gentoo-3478887cc8b1243d8cfd8fc4a247403476e5e69a.tar.bz2
gentoo-3478887cc8b1243d8cfd8fc4a247403476e5e69a.zip
media-libs/aften: Declare mycmakeargs to be an array
Gentoo-Bug: 573152 * EAPI=6 * Amend patch to be -p1 compliant Package-Manager: portage-2.2.27
-rw-r--r--media-libs/aften/aften-0.0.8-r1.ebuild36
-rw-r--r--media-libs/aften/files/aften-0.0.8-ppc.patch16
2 files changed, 44 insertions, 8 deletions
diff --git a/media-libs/aften/aften-0.0.8-r1.ebuild b/media-libs/aften/aften-0.0.8-r1.ebuild
new file mode 100644
index 000000000000..b07f04fa12bd
--- /dev/null
+++ b/media-libs/aften/aften-0.0.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An A/52 (AC-3) audio encoder"
+HOMEPAGE="http://aften.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cxx"
+
+PATCHES=(
+ "${FILESDIR}/${P}-multilib.patch"
+ "${FILESDIR}/${P}-ppc.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DSHARED=1
+ -DBINDINGS_CXX=$(usex cxx)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README Changelog
+ # File collision with media-sound/wavbreaker, upstream informed
+ mv "${D}"/usr/bin/wavinfo{,-aften} || die
+}
diff --git a/media-libs/aften/files/aften-0.0.8-ppc.patch b/media-libs/aften/files/aften-0.0.8-ppc.patch
index a841acf8f568..f21d816b55ca 100644
--- a/media-libs/aften/files/aften-0.0.8-ppc.patch
+++ b/media-libs/aften/files/aften-0.0.8-ppc.patch
@@ -1,7 +1,7 @@
Index: libaften/ppc/ppc_cpu_caps.h
===================================================================
---- libaften/ppc/ppc_cpu_caps.h
-+++ libaften/ppc/ppc_cpu_caps.h
+--- aften-0.0.8/libaften/ppc/ppc_cpu_caps.h
++++ aften-0.0.8/libaften/ppc/ppc_cpu_caps.h
@@ -20,6 +20,7 @@
#ifndef PPC_CPU_CAPS_H
#define PPC_CPU_CAPS_H
@@ -12,8 +12,8 @@ Index: libaften/ppc/ppc_cpu_caps.h
Index: libaften/ppc/mdct_altivec.c
===================================================================
---- libaften/ppc/mdct_altivec.c (revision 659)
-+++ libaften/ppc/mdct_altivec.c (revision 660)
+--- aften-0.0.8/libaften/ppc/mdct_altivec.c (revision 659)
++++ aften-0.0.8/libaften/ppc/mdct_altivec.c (revision 660)
@@ -47,11 +47,11 @@
#include "mem.h"
@@ -58,8 +58,8 @@ Index: libaften/ppc/mdct_altivec.c
Index: libaften/ppc/altivec_common.h
===================================================================
---- libaften/ppc/altivec_common.h (revision 659)
-+++ libaften/ppc/altivec_common.h (revision 660)
+--- aften-0.0.8/libaften/ppc/altivec_common.h (revision 659)
++++ aften-0.0.8/libaften/ppc/altivec_common.h (revision 660)
@@ -28,11 +28,23 @@
typedef vector unsigned int vec_u32_t;
typedef vector signed int vec_s32_t;
@@ -84,8 +84,8 @@ Index: libaften/ppc/altivec_common.h
static inline vector float vec_ld_float(const float *a)
{
---- ppc_cpu_caps.bak 2007-12-23 17:13:33.000000000 +0000
-+++ libaften/ppc/ppc_cpu_caps.c 2007-12-23 17:13:43.000000000 +0000
+--- aften-0.0.8/ppc_cpu_caps.bak 2007-12-23 17:13:33.000000000 +0000
++++ aften-0.0.8/libaften/ppc/ppc_cpu_caps.c 2007-12-23 17:13:43.000000000 +0000
@@ -81,7 +81,7 @@
//Attempt to use AltiVec
if(!sigsetjmp(g_env, 0))