summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-12-05 15:01:34 -0600
committerBen Kohler <bkohler@gentoo.org>2019-12-05 15:07:45 -0600
commit34e7d0b4266fec1978becc21bf02d8ff798e17da (patch)
treec4dcb56443172a1667a1c609740c017e69a3dbd1
parentapp-portage/smart-live-rebuild: Python 3.8 compatibility (diff)
downloadgentoo-34e7d0b4266fec1978becc21bf02d8ff798e17da.tar.gz
gentoo-34e7d0b4266fec1978becc21bf02d8ff798e17da.tar.bz2
gentoo-34e7d0b4266fec1978becc21bf02d8ff798e17da.zip
dev-python/paver: add missing six dep, and add python3_7
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--dev-python/paver/paver-1.3.4-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/paver/paver-1.3.4-r1.ebuild b/dev-python/paver/paver-1.3.4-r1.ebuild
new file mode 100644
index 000000000000..7dfbcd902d82
--- /dev/null
+++ b/dev-python/paver/paver-1.3.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+MY_PN=${PN/p/P}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python-based software project scripting tool along the lines of Make"
+HOMEPAGE="http://www.blueskyonmars.com/projects/paver/ https://github.com/paver/paver"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # https://github.com/paver/paver/issues/143#issuecomment-103943327
+ find paver/tests -name '*.pyc' -delete || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}