summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-14 17:33:31 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-14 17:34:50 +0100
commit352af7764e6017fa93ce648c186ebb8cf6db5aa8 (patch)
treefd3f35e2be7c5c82ab0c6d14ea00e0ce8442b3e9
parentdev-util/strace: Bump to version 5.10 (diff)
downloadgentoo-352af7764e6017fa93ce648c186ebb8cf6db5aa8.tar.gz
gentoo-352af7764e6017fa93ce648c186ebb8cf6db5aa8.tar.bz2
gentoo-352af7764e6017fa93ce648c186ebb8cf6db5aa8.zip
xfce-base/garcon: Update icon cache
Closes: https://bugs.gentoo.org/760015 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/garcon/garcon-0.7.3.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/xfce-base/garcon/garcon-0.7.3.ebuild b/xfce-base/garcon/garcon-0.7.3.ebuild
index 1f205f520f8f..6433ea9ccb51 100644
--- a/xfce-base/garcon/garcon-0.7.3.ebuild
+++ b/xfce-base/garcon/garcon-0.7.3.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit xdg-utils
+
DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
HOMEPAGE="https://docs.xfce.org/xfce/exo/start"
SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
@@ -39,3 +41,11 @@ src_install() {
find "${D}" -name '*.la' -delete || die
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}