summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-12-08 15:06:27 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-12-08 15:07:27 -0600
commit355d0a6b82e0b02b06739bee7ed3975d781971ea (patch)
treeb8dd57b4f90c0204338cf590be2db02a9cc47fdb
parentapp-crypt/certbot: 1.22.0 bump (diff)
downloadgentoo-355d0a6b82e0b02b06739bee7ed3975d781971ea.tar.gz
gentoo-355d0a6b82e0b02b06739bee7ed3975d781971ea.tar.bz2
gentoo-355d0a6b82e0b02b06739bee7ed3975d781971ea.zip
app-crypt/certbot-apache: 1.22.0 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.22.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index ef3f5dfec01f..6a8df09af7fb 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,3 +1,4 @@
DIST certbot-1.19.0.tar.gz 1338653 BLAKE2B b6ed909da2aed9853cf3dc6b936c513f33a127548ee30ac45a32a682141c5e4e79401ea328b7caf4e28d1d85aa2a9831e93deaa26c93216708a33be465dc8387 SHA512 2c1beb8c06299b9003fafd970cd3e977db85c4e84f1bf710166b7a99035b5c43a2a222d8d51513ac595255dd8eda02a1fb834c01ce68921927715c880052536e
DIST certbot-1.20.0.tar.gz 1339066 BLAKE2B 01278a53ea7166037c039d270ddd11a10c0570a9f038571dc6791e51f214fbff1589371b40c0dc73cbc18ed2005cfc231452bd00b039841a09ddb3c65d4ab122 SHA512 d35b2574811ac896ad119355be3a901438400e81a67388bd93290c4e7e9f6fa60dad99b51bc9bac7a7ac60714ed8bb6f60f522ce1a1a169886d0a15f0d0e371b
DIST certbot-1.21.0.tar.gz 1343180 BLAKE2B 79bbaafe96bca4cee9aabb39f4e9f1f12be4d2e1d9c1b156966061606ac3b07e5d80c5053baa03698e5513477076ca8f604aff43f77ee7f45d70d4b88429a875 SHA512 11ea781c5113cf68e3a76cafc2cf38d5ebc9cdb2f40a79eae0cdeac5d40f8dac05a4c71a269d5a6ff78027a1db0676195a8413e28a87d00aaf1602f6f2ce5b5e
+DIST certbot-1.22.0.tar.gz 1352714 BLAKE2B 213dc08d3a88e0d20d6324c026a47eb96b9e45fbde41f79e37c2e62c655d7c6df01292e110d2e78ea085dfc62ef3c7b623279224029c9ae2a59e69c5c00054a5 SHA512 9a7a0d11e9fd5bd59b526a2cc5d0029b972e34a2bf41035c2d8ab535b93fc6d985ee8ea3dd5e50a7f4af80450135b739d1297245ad21b47b8362cddb03738932
diff --git a/app-crypt/certbot-apache/certbot-apache-1.22.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.22.0.ebuild
new file mode 100644
index 000000000000..b46b10fa3536
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.22.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest