summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-07-27 08:44:39 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-27 08:45:11 +0200
commit362ac174a1ebbfe4514ddc06a0c733a2f2580558 (patch)
treee855ab6847fe158e0a8a034e2c5cc4098fe6ca52
parentx11-plugins/pidgin-skypeweb: Fix typo in SRC_URI. (diff)
downloadgentoo-362ac174a1ebbfe4514ddc06a0c733a2f2580558.tar.gz
gentoo-362ac174a1ebbfe4514ddc06a0c733a2f2580558.tar.bz2
gentoo-362ac174a1ebbfe4514ddc06a0c733a2f2580558.zip
app-text/enchant: Fixed compilation with hunspell-1.4 (bug #583486).
Bumped to EAPI-6. Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-text/enchant/enchant-1.6.0.ebuild9
-rw-r--r--app-text/enchant/files/enchant-1.6.0-hunspell140_fix.patch16
2 files changed, 23 insertions, 2 deletions
diff --git a/app-text/enchant/enchant-1.6.0.ebuild b/app-text/enchant/enchant-1.6.0.ebuild
index 1e8800f61b82..958d6b0892d6 100644
--- a/app-text/enchant/enchant-1.6.0.ebuild
+++ b/app-text/enchant/enchant-1.6.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit eutils autotools
@@ -30,7 +30,12 @@ REQUIRED_USE="|| ( hunspell aspell zemberek )"
DOCS="AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+PATCHES=(
+ "${FILESDIR}/${P}-hunspell140_fix.patch"
+)
+
src_prepare() {
+ default
sed -i \
-e 's:noinst_PROGRAMS:check_PROGRAMS:' \
tests/Makefile.am || die
diff --git a/app-text/enchant/files/enchant-1.6.0-hunspell140_fix.patch b/app-text/enchant/files/enchant-1.6.0-hunspell140_fix.patch
new file mode 100644
index 000000000000..5d58ab7f540c
--- /dev/null
+++ b/app-text/enchant/files/enchant-1.6.0-hunspell140_fix.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/583486
+http://bugzilla.abisource.com/show_bug.cgi?id=13772
+
+--- enchant-1.6.0/src/myspell/myspell_checker.cpp
++++ enchant-1.6.0/src/myspell/myspell_checker.cpp
+@@ -148,6 +148,10 @@
+ g_iconv_close(m_translate_out);
+ }
+
++#ifndef MAXWORDLEN
++# define MAXWORDLEN 100
++#endif
++
+ bool
+ MySpellChecker::checkWord(const char *utf8Word, size_t len)
+ {