summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-31 11:04:26 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-04 22:55:55 +0100
commit398d7df6783c137e1021410de38a4379ca736c55 (patch)
treed1251e6279b74202def04e6102b7a39ed28335aa
parentdev-lang/jimtcl: Clean old up (diff)
downloadgentoo-398d7df6783c137e1021410de38a4379ca736c55.tar.gz
gentoo-398d7df6783c137e1021410de38a4379ca736c55.tar.bz2
gentoo-398d7df6783c137e1021410de38a4379ca736c55.zip
dev-lang/jimtcl: Stop using awful multijob_* logic
The multijob logic adds a lot of complex, unmaintained and fragile bash code with little gain. Moreover, makes build logs unreadable by interspersing output from multiple configure runs. Bug: https://bugs.gentoo.org/613322
-rw-r--r--dev-lang/jimtcl/jimtcl-0.76.ebuild8
-rw-r--r--dev-lang/jimtcl/jimtcl-9999.ebuild8
2 files changed, 6 insertions, 10 deletions
diff --git a/dev-lang/jimtcl/jimtcl-0.76.ebuild b/dev-lang/jimtcl/jimtcl-0.76.ebuild
index 3d5515b2e63d..166bf52e88b0 100644
--- a/dev-lang/jimtcl/jimtcl-0.76.ebuild
+++ b/dev-lang/jimtcl/jimtcl-0.76.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit multiprocessing eutils
+inherit eutils
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
@@ -40,15 +40,13 @@ src_prepare() {
}
src_configure() {
- multijob_init
- CCACHE=None multijob_child_init econf --with-jim-shared
+ CCACHE=None econf --with-jim-shared
if use static-libs ; then
# The build does not support doing both simultaneously.
mkdir static-libs
cd static-libs
- CCACHE=None ECONF_SOURCE=${S} multijob_child_init econf
+ CCACHE=None ECONF_SOURCE=${S} econf
fi
- multijob_finish
}
src_compile() {
diff --git a/dev-lang/jimtcl/jimtcl-9999.ebuild b/dev-lang/jimtcl/jimtcl-9999.ebuild
index 3c79869f318e..c3f079c046f3 100644
--- a/dev-lang/jimtcl/jimtcl-9999.ebuild
+++ b/dev-lang/jimtcl/jimtcl-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit multiprocessing eutils
+inherit eutils
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
@@ -40,15 +40,13 @@ src_prepare() {
}
src_configure() {
- multijob_init
- CCACHE=None multijob_child_init econf --with-jim-shared
+ CCACHE=None econf --with-jim-shared
if use static-libs ; then
# The build does not support doing both simultaneously.
mkdir static-libs
cd static-libs
- CCACHE=None ECONF_SOURCE=${S} multijob_child_init econf
+ CCACHE=None ECONF_SOURCE=${S} econf
fi
- multijob_finish
}
src_compile() {