summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-19 07:22:45 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-19 07:22:45 +0200
commit3add991ac754831e672ac4acfd5cf53820461442 (patch)
tree281a536fa2c43148b433fafde0ecbba5d6bd1c0c
parentdev-ruby/patron: move ~ppc keyword forward (diff)
downloadgentoo-3add991ac754831e672ac4acfd5cf53820461442.tar.gz
gentoo-3add991ac754831e672ac4acfd5cf53820461442.tar.bz2
gentoo-3add991ac754831e672ac4acfd5cf53820461442.zip
dev-ruby/patron: add 0.9.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-ruby/patron/Manifest1
-rw-r--r--dev-ruby/patron/patron-0.9.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/patron/Manifest b/dev-ruby/patron/Manifest
index c9ccbd3d3127..7f063ff81a7f 100644
--- a/dev-ruby/patron/Manifest
+++ b/dev-ruby/patron/Manifest
@@ -1,3 +1,4 @@
DIST patron-0.4.18.gem 35840 SHA256 700ffba09ea854bc26fdde08998d8310ed59b0721098d4a7dc9a85845c71bd81 SHA512 0069f42378b0dfe03e6f86003b7927b099fd15be4d4b5eeba51958774380bf7a9ddbd8a83b30942d02e95b923f9ae0a1c1abf5bcda8ca8490671208e0ae8ecb4 WHIRLPOOL c709bcd65033288fc55d8d5c044c001afa8ac34d098466e017c5adc3a08314897e86f021a09f61abcc5153893152518dc1843ba7dfa79fc271067b708283b75c
DIST patron-0.5.0.gem 44032 SHA256 6abf431b05f560afc8c479685bb3869797522290777a1ae8510ef5c8b3208c63 SHA512 84c4cbb4ebeac3a9320915b35e4afefda5637f1bed96e83b8c2345dfd08ba02e07806b13a87c5067dd842ccddb67928c7f60889687676c0683d4e09373d8c2a7 WHIRLPOOL df34adeb59ea45d5d84a6ad1aef3e0fbf4781720443be2ba37450ddf2e51ac3b2c969bb2798fe78bb476cde79f4ccc3d3c1f6511a20dc2deda5a750ec9d03139
DIST patron-0.8.0.gem 57856 SHA256 954db224e16421c78c55d190b2310c3201c68e72767908faead76a9c5a5159df SHA512 43d6ae99aa3db3c5dabd2c3ec7fe5371a204d6e6ccec2c50b0cc126878b0db583e8a266b2b8e0f3ce7cdfde046bd36622e26d653e7ccae7b493ec924021b5f16 WHIRLPOOL b176ced2464b52c3a1bd4412e8c5d0ca7c3c8ee6da2c7c59cf4442c04eeefd07cd6c1c76d93cb2c6ba63c51326d8e1c317e760bf7bbf7506f43ca923a105c04a
+DIST patron-0.9.1.gem 59904 SHA256 6d5d2e89ab551d081dce572d2fbfed4e98ee7e7dccc144a69bcc17c7ad955ef3 SHA512 649ee01517369d44009ccf5af4ac5f758893df84259b604be2f5015f9a9015a20a60eb2d6de9873ffa800c49a080e458d2a451222af4783261991c6c134785f7 WHIRLPOOL c10234d797e3a52e49fb25a9be6c468066e3792bedd00fe14165b514e91712a9b19accc4a1d5c1741da2ba5cc6541f25e4f62ccab77248fcfd9bac5ec55daf19
diff --git a/dev-ruby/patron/patron-0.9.1.ebuild b/dev-ruby/patron/patron-0.9.1.ebuild
new file mode 100644
index 000000000000..aad086404b02
--- /dev/null
+++ b/dev-ruby/patron/patron-0.9.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="https://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+all_ruby_prepare() {
+ # Fix Rakefile
+ sed -i -e 's:rake/rdoctask:rdoc/task:' \
+ -e 's/README.txt/README.md/' \
+ -e '/bundler/I s:^:#:' \
+ -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' \
+ Rakefile || die
+
+ # Avoid specs with failures. We were not running any specs before.
+ rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}