summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Günzler <r@gnzler.io>2021-04-25 19:08:49 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-05-05 09:41:59 +0300
commit3b2cf4ac5611d35a8a0d5dfaee2047f369304256 (patch)
tree4911eab16af3c8295a203052fb9fcaf860ea127b
parentapp-emulation/crun: bump to 0.19.1 (diff)
downloadgentoo-3b2cf4ac5611d35a8a0d5dfaee2047f369304256.tar.gz
gentoo-3b2cf4ac5611d35a8a0d5dfaee2047f369304256.tar.bz2
gentoo-3b2cf4ac5611d35a8a0d5dfaee2047f369304256.zip
app-emulation/crun: drop 0.17
Signed-off-by: Robert Günzler <r@gnzler.io> Closes: https://github.com/gentoo/gentoo/pull/20539 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-emulation/crun/Manifest1
-rw-r--r--app-emulation/crun/crun-0.17.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/app-emulation/crun/Manifest b/app-emulation/crun/Manifest
index 698b3677ff45..d26a51b14daf 100644
--- a/app-emulation/crun/Manifest
+++ b/app-emulation/crun/Manifest
@@ -1,3 +1,2 @@
-DIST crun-0.17.tar.gz 1385658 BLAKE2B 3d4c30989b9e79d02bf9a6c298daa8d0b5b6b8bfcfaca8ae9e27ad865762a32b6af2c8806586bba2ab94271446a93c34e8f2d465cc008c41bbe69e565556a1b1 SHA512 b095a3c4fca8ae683553805de468594e8dd891cc9911b56e8be7c429584e71fb40a364cf55a6a829950078a539d35308310f53f57b8fb40d483d394e91b20b01
DIST crun-0.18.tar.gz 1394857 BLAKE2B db4f0407aaf5e4c5b9069ad5ae6a76308665d91559d92bf370b964e0914f337a84af896f1c1e00184ef4b0625bd1c0f1e2fc3295074c7f5524c5359ce54ba6b4 SHA512 94610d9d4ef95a9be708c6cf8cc38587c9c3b847d9da5cf9dfa4a2eddddb7e6724e39ffb222ed5d6c61bad8374ae50dc9e92d95b6d03ce0b185d5123afeeca46
DIST crun-0.19.1.tar.gz 1870594 BLAKE2B 1780a2936ff39ec80836c4c9ae072e2fc30703a31a79786337290c62dd433b5a35dcfa953be370703d1baab3de93fdb376c99ab76dff1470883c61726c313144 SHA512 f93f79d1d63d6749bcf92d48542d9555f3ad47657c959c7c06701861d7a5a4171969f00f6dff3878286970a48aba3314c25e35c005463e606533b0ff7843d994
diff --git a/app-emulation/crun/crun-0.17.ebuild b/app-emulation/crun/crun-0.17.ebuild
deleted file mode 100644
index bc97b2bddb13..000000000000
--- a/app-emulation/crun/crun-0.17.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit autotools python-any-r1
-
-DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
-HOMEPAGE="https://github.com/containers/crun"
-SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
-IUSE="+bpf +caps criu +seccomp systemd static-libs"
-
-DEPEND="
- sys-kernel/linux-headers
- >=dev-libs/yajl-2.0.0
- caps? ( sys-libs/libcap )
- criu? ( >=sys-process/criu-3.15 )
- seccomp? ( sys-libs/libseccomp )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
-"
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-RESTRICT="test"
-
-DOCS=( README.md )
-
-src_configure() {
- local myeconfargs=(
- $(use_enable bpf)
- $(use_enable caps)
- $(use_enable criu)
- $(use_enable seccomp)
- $(use_enable systemd)
- $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake -C libocispec
- emake crun
-}
-
-src_install() {
- emake "DESTDIR=${D}" install-exec
- doman crun.1
- einstalldocs
-}