summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2020-09-09 22:31:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-03 16:43:05 +0300
commit3c596be4f93965cfdaf1b200379c4fe5d9cba4ae (patch)
tree1001569cc4b71e0e8be7e115c202f256e909df2d
parentapp-misc/pwsafe: revbump (diff)
downloadgentoo-3c596be4f93965cfdaf1b200379c4fe5d9cba4ae.tar.gz
gentoo-3c596be4f93965cfdaf1b200379c4fe5d9cba4ae.tar.bz2
gentoo-3c596be4f93965cfdaf1b200379c4fe5d9cba4ae.zip
media-gfx/yafaray: add support for python-3.{7,8}
- Remove support for python-3.6 - Remove blender USE flag and support. The blender plugin isn't ready for blender-2.8 series yet. Blender-2.79 is python-3.6 only, which is going to be removed soon. Support will be re-added, as soon as upstream has updated the plugin for blender-2.8*. Closes: https://bugs.gentoo.org/737392 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17485 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-gfx/yafaray/Manifest1
-rw-r--r--media-gfx/yafaray/metadata.xml1
-rw-r--r--media-gfx/yafaray/yafaray-3.4.1.ebuild40
3 files changed, 5 insertions, 37 deletions
diff --git a/media-gfx/yafaray/Manifest b/media-gfx/yafaray/Manifest
index 0d86321f1fd2..eb4cb6dcc74b 100644
--- a/media-gfx/yafaray/Manifest
+++ b/media-gfx/yafaray/Manifest
@@ -1,2 +1 @@
-DIST yafaray-blender-exporter-3.4.1.tar.gz 381253 BLAKE2B b1483c79b14581729f598b92ca504af4a8a73cff54ff2014e8be646eaa2eea7f10074d1dc8c58251d8a987ac6e5ac10d1bc34b80c229f74e6d580bbaa3a3c461 SHA512 1f7baf7bf5953be8b4e004b1509cc23164df0a05e28d33a2301195ea21ad4d4cd6fdd67a0b1af11c1075bab7018e64b38f564be8b647d8513db46feee7d8bf85
DIST yafaray-core-3.4.1.tar.gz 1136077 BLAKE2B a2ce3945f52315084ee744ff4a6733255018196f0000ca6b1786fbd2ec49ade64cb62e98dfba95dca4dec361f47235d59a8c9bd95ee7d095214fc0afbdcb1ee4 SHA512 a9116273fbc2aaaadbc38a65b1eaaa502070ff06f8a2929e880714a9db57188e65cf319c20a3f96e08146af36a67aea139709a633eb024be65319a64330e6f68
diff --git a/media-gfx/yafaray/metadata.xml b/media-gfx/yafaray/metadata.xml
index 795c6e4891e0..24519079a75e 100644
--- a/media-gfx/yafaray/metadata.xml
+++ b/media-gfx/yafaray/metadata.xml
@@ -14,7 +14,6 @@
An render engine consists of a "faceless" computer program that interacts with a host 3D application to provide very specific raytracing capabilties "on demand". Blender 3D is the host application of YafaRay.
</longdescription>
<use>
- <flag name="blender">Install addon for <pkg>media-gfx/blender</pkg></flag>
<flag name="fastmath">Enable mathematic approximations to make code faster</flag>
<flag name="fasttrig">Enable trigonometric approximations to make code faster</flag>
<flag name="opencv">Use <pkg>media-libs/opencv</pkg></flag>
diff --git a/media-gfx/yafaray/yafaray-3.4.1.ebuild b/media-gfx/yafaray/yafaray-3.4.1.ebuild
index e583d32d4b7c..4efd96180ca1 100644
--- a/media-gfx/yafaray/yafaray-3.4.1.ebuild
+++ b/media-gfx/yafaray/yafaray-3.4.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{7,8} )
# doesn't build with ninja when qt5 and python USE flags are both enabled
CMAKE_MAKEFILE_GENERATOR="emake"
@@ -12,19 +12,17 @@ inherit cmake flag-o-matic python-single-r1
DESCRIPTION="A free open-source montecarlo raytracing engine"
HOMEPAGE="http://www.yafaray.org"
-SRC_URI="https://github.com/YafaRay/Core/archive/v${PV}.tar.gz -> ${PN}-core-${PV}.tar.gz
- blender? ( https://github.com/YafaRay/Blender-Exporter/archive/v${PV}.tar.gz -> ${PN}-blender-exporter-${PV}.tar.gz )"
+SRC_URI="https://github.com/YafaRay/Core/archive/v${PV}.tar.gz -> ${PN}-core-${PV}.tar.gz"
S="${WORKDIR}/Core-${PV}"
-LICENSE="blender? ( GPL-2+ ) LGPL-2.1"
+LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="blender +fastmath +fasttrig jpeg opencv openexr png +python qt5 tiff truetype"
+IUSE="+fastmath +fasttrig jpeg opencv openexr png +python qt5 tiff truetype"
RESTRICT="test"
REQUIRED_USE="
- blender? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
"
@@ -37,10 +35,7 @@ RDEPEND="
opencv? ( >=media-libs/opencv-3.1.0:= )
openexr? ( >=media-libs/openexr-2.2.0:= )
png? ( media-libs/libpng:0= )
- python? (
- ${PYTHON_DEPS}
- blender? ( ~media-gfx/blender-2.79b[${PYTHON_SINGLE_USEDEP}] )
- )
+ python? ( ${PYTHON_DEPS} )
qt5? ( dev-qt/qtwidgets:5 )
tiff? ( media-libs/tiff:0 )
truetype? ( media-libs/freetype:2 )
@@ -63,13 +58,6 @@ src_prepare() {
append-ldflags -pthread
cmake_src_prepare
-
- if use blender; then
- # fix PLUGIN_PATH
- sed -e "s/PLUGIN_PATH = os.path.join(__path__\[0\], 'bin'/PLUGIN_PATH = os.path.join(__path__\[0\], '"$(get_libdir)"'/" \
- -e "s/@YAFARAY_BLENDER_EXPORTER_VERSION@/v"${PV}"/" \
- -i "${WORKDIR}"/Blender-Exporter-${PV}/__init__.py || die "patching startup file failed"
- fi
}
src_configure() {
@@ -116,18 +104,6 @@ src_install() {
fi
rm -rv "${ED}"/usr/share/doc/${PN} || die
-
- if use blender; then
- pushd "${WORKDIR}/Blender-Exporter-${PV}" || die
- # grab blender version number for plugin directory
- local blender_plugin_dir=$(best_version media-gfx/blender)
- blender_plugin_dir=${blender_plugin_dir##*/} # remove category
- blender_plugin_dir=${blender_plugin_dir#*-} # remove package name
- blender_plugin_dir=${blender_plugin_dir%%-*} # remove revision number if exists
- insinto /usr/share/blender/${blender_plugin_dir}/scripts/addons/yafaray_v3
- doins -r .
- popd || die
- fi
}
pkg_postinst() {
@@ -135,10 +111,4 @@ pkg_postinst() {
einfo "yafaray-xml with /usr/share/yafaray/tests/test01/test01.xml"
einfo "as an input file, then compare the result to"
einfo "'/usr/share/yafaray/tests/test01/test01 - expected render result.png'"
- if use blender; then
- elog
- elog "To use within Blender, navigate to File -> User Preferences -> Add-ons (tab)"
- elog "and enable 'Render: YafaRay v3 Exporter'. This will make YafaRay available"
- elog "in the render engines drop-down."
- fi
}