summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-06-12 13:49:01 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-06-12 13:55:49 +0200
commit3cd767408ba7be2044d31fb169aed20e03beda44 (patch)
tree418c9a1630eea6100fea4fead615f14f4f866c64
parentapp-crypt/keybase: Add warning to remove obsolete user (diff)
downloadgentoo-3cd767408ba7be2044d31fb169aed20e03beda44.tar.gz
gentoo-3cd767408ba7be2044d31fb169aed20e03beda44.tar.bz2
gentoo-3cd767408ba7be2044d31fb169aed20e03beda44.zip
app-emulation/reg: Version bump to 0.13.3
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-emulation/reg/Manifest1
-rw-r--r--app-emulation/reg/reg-0.13.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emulation/reg/Manifest b/app-emulation/reg/Manifest
index fb3513d706c0..f2a9c31b3d0f 100644
--- a/app-emulation/reg/Manifest
+++ b/app-emulation/reg/Manifest
@@ -1 +1,2 @@
DIST reg-0.13.1.tar.gz 2931156 BLAKE2B 56245364c348f800e77b25d4c7326a721bd041ac865aa4ac55eefa60a6d1746176e109247967f42bc48727c56fd91c47f2d76aa245f208aff64a26b77b4394f8 SHA512 c64b5a21cb5f2e3d64d9a80309a2eab3e1002b6aba1a59b87d873326e9c2c722ccbfa0778aa14a2cc1fca86dcd3ad1bf7eeef3e7293c835fef00e11e413decfb
+DIST reg-0.13.3.tar.gz 5396000 BLAKE2B c5fa658010cb5c1cc21d7edfc1b18fac8c65cf2bd3c6de213ab238aabcb1377096172b5484a92f18a04f9ef4c01124dcfcfd4e6eabaf9f9a9b272c6f1f1fc482 SHA512 aefe0e5d3b1a02d54e67a4c7892e6b6c7581793f9e45995933200125c275e38701ad25b772c4541714f72ad1b43865e484bd062e40edbb7ed5faf2a572c224a1
diff --git a/app-emulation/reg/reg-0.13.3.ebuild b/app-emulation/reg/reg-0.13.3.ebuild
new file mode 100644
index 000000000000..25b44103626a
--- /dev/null
+++ b/app-emulation/reg/reg-0.13.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/reg"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="f143bb56a5d7ade706e45a0d8b59d2f1ca35724d"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Docker registry v2 command line client"
+HOMEPAGE="https://github.com/genuinetools/reg"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc src/${EGO_PN}/README.md
+}