summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-12 16:58:59 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-12 17:40:16 +0200
commit3d915b9a36c4158c98b12f0c4da7a25dde8034b0 (patch)
tree9b662b665786c19f27f82754f5bdcf358a3104a7
parentdev-python/async_timeout: Port to py3.9 (diff)
downloadgentoo-3d915b9a36c4158c98b12f0c4da7a25dde8034b0.tar.gz
gentoo-3d915b9a36c4158c98b12f0c4da7a25dde8034b0.tar.bz2
gentoo-3d915b9a36c4158c98b12f0c4da7a25dde8034b0.zip
dev-python/setproctitle: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild13
1 files changed, 1 insertions, 12 deletions
diff --git a/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild b/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild
index 0b893c76c410..a0662118eee3 100644
--- a/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild
+++ b/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# pypy doesn't get started in test run. Still required by www-servers/gunicorn
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 toolchain-funcs
@@ -24,17 +23,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
# Required for re-write of test suite
DISTUTILS_IN_SOURCE_BUILD=1
-python_compile_all() {
- # Make a nice html file
- rst2html.py README.rst > README.html
- # The README.rst will be duplicated in src_install
- rm README.rst || die
-}
-
python_test() {
- # The suite via the Makefile appears to not cater to pypy
- [[ ${EPYTHON} =~ pypy ]] && return
-
# prepare embedded executable
emake \
CC="$(tc-getCC)" \