summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 16:53:54 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:53:42 +0100
commit3db2a8e5781315769d8f4d58ba304cef474b7c04 (patch)
tree0ed905597cae6bfff8632c6fb96419ba1d2f74b0
parentnet-print/cups-filters: drop no-op USE=static-libs, phase order, || die (diff)
downloadgentoo-3db2a8e5781315769d8f4d58ba304cef474b7c04.tar.gz
gentoo-3db2a8e5781315769d8f4d58ba304cef474b7c04.tar.bz2
gentoo-3db2a8e5781315769d8f4d58ba304cef474b7c04.zip
sys-apps/fakeroot: drop no-op USE=static-libs
We add --disable-static just to be sure though. We were already unconditionally deleting both .la and .a, so the USE flag did nothing. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/fakeroot/fakeroot-1.22.ebuild7
-rw-r--r--sys-apps/fakeroot/fakeroot-1.23.ebuild7
-rw-r--r--sys-apps/fakeroot/fakeroot-1.24.ebuild7
-rw-r--r--sys-apps/fakeroot/fakeroot-1.25.1.ebuild7
-rw-r--r--sys-apps/fakeroot/fakeroot-1.25.2.ebuild7
5 files changed, 15 insertions, 20 deletions
diff --git a/sys-apps/fakeroot/fakeroot-1.22.ebuild b/sys-apps/fakeroot/fakeroot-1.22.ebuild
index 1f8e88f9076b..5c9e0a601819 100644
--- a/sys-apps/fakeroot/fakeroot-1.22.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="acl debug static-libs test"
+IUSE="acl debug test"
RESTRICT="!test? ( test )"
DEPEND="
@@ -36,8 +36,7 @@ src_configure() {
export ac_cv_header_sys_acl_h=$(usex acl)
use debug && append-cppflags "-DLIBFAKEROOT_DEBUGGING"
- econf \
- $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {
diff --git a/sys-apps/fakeroot/fakeroot-1.23.ebuild b/sys-apps/fakeroot/fakeroot-1.23.ebuild
index c0f5629f8051..8ff11f2bd082 100644
--- a/sys-apps/fakeroot/fakeroot-1.23.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="acl debug static-libs test"
+IUSE="acl debug test"
RESTRICT="!test? ( test )"
DEPEND="
@@ -36,8 +36,7 @@ src_configure() {
export ac_cv_header_sys_acl_h=$(usex acl)
use debug && append-cppflags "-DLIBFAKEROOT_DEBUGGING"
- econf \
- $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {
diff --git a/sys-apps/fakeroot/fakeroot-1.24.ebuild b/sys-apps/fakeroot/fakeroot-1.24.ebuild
index 1145abde6854..c0433bfb258d 100644
--- a/sys-apps/fakeroot/fakeroot-1.24.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.24.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="acl debug static-libs test"
+IUSE="acl debug test"
RESTRICT="!test? ( test )"
DEPEND="
@@ -36,8 +36,7 @@ src_configure() {
export ac_cv_header_sys_acl_h=$(usex acl)
use debug && append-cppflags "-DLIBFAKEROOT_DEBUGGING"
- econf \
- $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {
diff --git a/sys-apps/fakeroot/fakeroot-1.25.1.ebuild b/sys-apps/fakeroot/fakeroot-1.25.1.ebuild
index eac32e7e9542..acc86b8534df 100644
--- a/sys-apps/fakeroot/fakeroot-1.25.1.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.25.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="acl debug static-libs test"
+IUSE="acl debug test"
RESTRICT="!test? ( test )"
DEPEND="
@@ -41,8 +41,7 @@ src_configure() {
export ac_cv_header_sys_acl_h=$(usex acl)
use debug && append-cppflags "-DLIBFAKEROOT_DEBUGGING"
- econf \
- $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {
diff --git a/sys-apps/fakeroot/fakeroot-1.25.2.ebuild b/sys-apps/fakeroot/fakeroot-1.25.2.ebuild
index eac32e7e9542..acc86b8534df 100644
--- a/sys-apps/fakeroot/fakeroot-1.25.2.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.25.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="acl debug static-libs test"
+IUSE="acl debug test"
RESTRICT="!test? ( test )"
DEPEND="
@@ -41,8 +41,7 @@ src_configure() {
export ac_cv_header_sys_acl_h=$(usex acl)
use debug && append-cppflags "-DLIBFAKEROOT_DEBUGGING"
- econf \
- $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {