summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-29 12:50:58 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-29 14:32:13 -0500
commit3e9055c6596ba0d36dab58a623866ff840232450 (patch)
tree433f36a163ed4a280a9a93a16bda6092256d03d1
parentsys-apps/apmd: use #!/sbin/openrc-run instead of #!/sbin/runscript (diff)
downloadgentoo-3e9055c6596ba0d36dab58a623866ff840232450.tar.gz
gentoo-3e9055c6596ba0d36dab58a623866ff840232450.tar.bz2
gentoo-3e9055c6596ba0d36dab58a623866ff840232450.zip
sys-apps/nca: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
-rw-r--r--sys-apps/nca/files/ncad.initd4
-rw-r--r--sys-apps/nca/nca-0.9.0-r1.ebuild44
2 files changed, 46 insertions, 2 deletions
diff --git a/sys-apps/nca/files/ncad.initd b/sys-apps/nca/files/ncad.initd
index 5e7fff2fed87..f87ec3260785 100644
--- a/sys-apps/nca/files/ncad.initd
+++ b/sys-apps/nca/files/ncad.initd
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/sys-apps/nca/nca-0.9.0-r1.ebuild b/sys-apps/nca/nca-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..d4abf437885b
--- /dev/null
+++ b/sys-apps/nca/nca-0.9.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Network Console on Acid"
+HOMEPAGE="http://www.xenoclast.org/nca/"
+SRC_URI="http://www.xenoclast.org/nca/download/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl
+ sys-libs/zlib"
+
+DEPEND="dev-lang/perl
+ ${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s:^\([[:space:]]\+\$(MAKE) install\):\1 DESTDIR=\$(DESTDIR):g" \
+ -e "s:=\(\$(CFLAGS)\):=\"\1\":g" -e "s:=\(\$(CC)\):=\"\1\":g" Makefile
+
+ sed -i -e "s:-s sshd:sshd:g" ncad.patch
+
+ eapply_user
+}
+
+src_compile() {
+ emake -j1 CFLAGS="${CFLAGS}" CC=$(tc-getCC)
+}
+
+src_install() {
+ dodir /sbin
+ emake BINDIR="${D}sbin" MANDIR="${D}usr/share/man" SYSCONF_DIR="${D}etc" \
+ DESTDIR="${D}" install_nca install_ssh install_man
+
+ newinitd "${FILESDIR}/ncad.initd" ncad
+ dodoc ChangeLog README* rc/ncad.template
+}