summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-24 10:06:11 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-24 10:52:34 +0100
commit3eb4ad235a17532d770de1ae13657158df65aab8 (patch)
treef37e82452447e26558440e9a89221381638b496a
parentdev-ml/ocaml-conduit: Bump to 0.15.0 (diff)
downloadgentoo-3eb4ad235a17532d770de1ae13657158df65aab8.tar.gz
gentoo-3eb4ad235a17532d770de1ae13657158df65aab8.tar.bz2
gentoo-3eb4ad235a17532d770de1ae13657158df65aab8.zip
dev-ml/ocaml-dns: Bump to 0.19.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-ml/ocaml-dns/Manifest1
-rw-r--r--dev-ml/ocaml-dns/ocaml-dns-0.19.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dns/Manifest b/dev-ml/ocaml-dns/Manifest
index 4f12e5a0a532..6ed5fd3b08eb 100644
--- a/dev-ml/ocaml-dns/Manifest
+++ b/dev-ml/ocaml-dns/Manifest
@@ -1 +1,2 @@
DIST ocaml-dns-0.18.1.tar.gz 144857 SHA256 c570a9f215bbafacb83319fd1d21fd393357c97359c237b941767d81764cc5e6 SHA512 909e7de8b434769aee04c4837cbcecd2856ad11b863f061eca650621b0caab81327107b58ecf20d65270f36b192d438baa3868b906cd9243163b2c697bf68684 WHIRLPOOL 043200a93926bc67859e6ff6f03ecfc1184ad3e13595fa71891a9e8ba3932ab2d3e46f32a145b11989d185e519548693af605b617ce7914dda1711d40a2d2d88
+DIST ocaml-dns-0.19.0.tar.gz 150398 SHA256 d9591f8cc3498667e66683251e68e3e32ff3c1f7cc7cf36d945c2706f96854fd SHA512 3b885bb202bd32b9a9961e3f971fe8c404b7585f27214076c09a0c524a8f382d1f584843237169b51e209dee401a630f6240c3789ac1d2d6980e15feb3e508df WHIRLPOOL 100215eb9c8ab867056eb849917d96408380cc9f9a1447b1f29c6fae03a0ed44c6e74fb461bee8f54f7f521ff5ab7270c7eb38ef0685a6010bdba17903eaf400
diff --git a/dev-ml/ocaml-dns/ocaml-dns-0.19.0.ebuild b/dev-ml/ocaml-dns/ocaml-dns-0.19.0.ebuild
new file mode 100644
index 000000000000..72a6d3101367
--- /dev/null
+++ b/dev-ml/ocaml-dns/ocaml-dns-0.19.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml implementation of the DNS protocol"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt"
+
+RDEPEND="
+ async? ( >=dev-ml/async-112.24.00:= )
+ lwt? ( >=dev-ml/lwt-2.4.7:=
+ dev-ml/ocaml-cstruct:=[lwt(-)] )
+ >=dev-lang/ocaml-4:=
+ dev-ml/cmdliner:=
+ dev-ml/mirage-profile:=
+ >=dev-ml/ocaml-base64-2.0.0:=
+ >=dev-ml/ocaml-cstruct-1.9.0:=
+ >=dev-ml/ocaml-ipaddr-2.6.0:=
+ dev-ml/ocaml-re:=
+ >=dev-ml/ocaml-uri-1.7.0:=
+ dev-ml/ocaml-hashcons:=[ocamlopt?]
+ !<dev-ml/mirage-types-1.2.0
+ !dev-ml/odns
+"
+DEPEND="
+ test? ( dev-ml/ounit
+ dev-ml/ocaml-pcap )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable async)
+ $(use_enable lwt)
+ $(use_enable test nettests)
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )